Cant connect core to wifi and CLI doesnt make it through all steps

Hi folks,

I just received my first core a few weeks ago and Ive been trying to get it up and running, but was unsuccessful. Here’s what Ive tried:

My WIFI set up:
802.11 b/g/n (that was the only other option it gave me other than g/n)
WPA WPA2
2.4GHz

First Try:
Downloaded android app and tried to connect to the wifi, but failed and never found any cores. I went through my wifi set up and made sure to change anything I could that may be interfering with the set up. I also looked through the online documentation Particle provides for trouble shooting. Nothing seemed to work. And I could not connect through the app.

Second Try:
Installed CLI on Ubuntu 14.04 64 bit VM
Ran through the instructions, and got to the point where it asks you to press enter when the LED shouts rainbows. I waiting a long time while it cycled through slow and fast blinking cyan. It never went to rainbows. But magically for some reason skipped that step on its own (meaning without input from me), I then gave input to claim the core and name the core. But it continued to cycle through fast and slow blinking cyan. So that worried me and I reset and tried again…

Third Try:
Again through the CLI, went throught all the steps. This time when it got to the step where it wants you to press enter when it shouts rainbows, it just continued to cycle through fast and slow blinking cyan, and never moved on from there. After leaving it for a few hours I gave up and quit the program.

Fourth Try:
Went through the CLI again, this time I pressed enter even though the core never went to rainbows. kept the same name as the first time i named the core. I can see on the dash board that is does have activity. To check I followed the post here.

This was my out put:

Including:
        /usr/local/lib/node_modules/particle-cli/binaries/spark_tinker.bin
attempting to flash firmware to your device glwcore
flash device said  {"ok":false,"code":500,"errors":[{"error":"Timed out."}]}

And it continues to switch between fast and slow blinking cyan.

Before I go on to re-install things or deep updates, etc. and other things I dont fully understand, I was hoping to get a few pointers from the forum here, just to make sure Ive done everything I should have.

Thanks!

It might be likely that the b/g/n setting is causing the issue.

It this a new core that has not been claimed yet?

The b/g/n issue is only likely to bite when attempting to do the claiming via WiFi, but when doing it via USB (CLI or serial monitor like PuTTY) it shouldn’t make a difference, since the Core only uses the b/g and ignores n.

On the other hand I can’t quite believe this

What brand router is it? Is there a setting to disable 5GHz instead?

thanks for your help on this guys…

Here’s a screen shot of my wifi options:

the wifi and router is provided by Comcast for their xfinity service. Its a router and wifi in one machine. The maker seems to be a company called arris.

I looked through the settings and there does not appear to be a way to disable 5GHz. It seems that 5GHz is not even provided

And I dont believe I have claimed the device yet, only named it…

It looks like this question got flagged as solved. I dont know if that was a fault of my own or not. But I am still unable to connect my core.

Any thoughts on the issue?

Thanks.

It is most likely an issue with router compatibility. Can you try connecting to a mobile hotspot and see if it works well?

Good idea. Ill give it a try and report back.

Hi @kennethlimcp I tried the mobile hotspot solution on my Nexus 5. But I was still getting the same results > Could not get past shouting rainbows on the command line.

Ok cool. Did you managed to claim it under our account yet? Do you see the Core as online?

Hi @kennethlimcp, sorry for the delay in my response. Just been busy lately…

Back to your question. I think I have claimed it since I was able to name it, and that named core does appear on my account. Also when the Core is trying to connect I do see activity through the dashboard. What i see is not a steady stream though of activity, only a spike when I am attempting to connect. Other attempts to communicate with the core fail.

If you see activity then the core is probably claimed under that account.

Can you do a factory reset on the Core and let me see how it goes?