Can't setup Core via WiFi or CLI [SOLVED - sort of]

Setting this thing up on wifi is impossible which defeats its purpose. However, I used USB which is cool and all. The problem is now I have the Core at home and since I cannot use the wifi to set it up, I need to use the USB again so I can get it on my network. I already have the newest version of NodeJS because I am a developer. I installed the CLI tools, made sure the drivers were installed. So far everything looks good. I run the CLI tools and it says it found my Core, and asks if i want to set it up. Then I get an error saying the serial port is closed. So what now?

Is the next version of this chip working correctly with wifi? Despite what the headaches this has been so far, I really want it to work and will totally set it aside until the new ones are available if it works correctly.

Hiya! Sorry you’re having trouble with it. The Photon’s certainly easier, but perhaps I can help ya here.

Now, I know this is going to sound like the old “is it plugged in?”, but is it currently in listening mode, where the main LED is blinking blue?

2 Likes

Its plugged in, in listening mode (blinking blue light), the drivers show up in the device manager and are properly installed, the cli tool says it sees it and the tool is logged into the my account that its registered to, it asks if I want to use the device it found.

On my work machine, the cli tool setup without issue (still wish it setup over the wireless, but I could deal), however on my home system, which has all the software setup identically, it is telling me the serial port is not open at that last step. I havent tried rebooting the machine yet because I am in the middle of transforming some data, but I hope that it is something that can be fixed without a reboot, because everyone hates reboots.

Also, I did verify that it is the correct COM port.

EDIT: Well nevermind. I just ran the setup utility again and for unknown reasons it just started working.

1 Like

Just wonder what does particle --version say?

Try particle serial list and see if it lists anything

1 Like

Crap, it failed during setup and is no longer working over serial…

When I use the serial list argument, it shows the SparkCore on COM13 where it is also in the device manager, so it sees it.

The version npm installed is 1.5.11

So particle serial list shows the core?

Cool you are on the latest particle-cli :smile:

If the core is listed, you can use particle serial wifi and send in wifi credentials

@iamthemadz, could you please alter this threads topic into something more precise to name the actual problem?

“There seriously has to be a fix for this” is not very helpful for people searching for help for their own problem and for people to assist it doesn’t help to distinguish if it refers to one of their fields of expertise or not, and forcing them to read into the thread just to find out they can’t really help anyway, may tie up some of their precious time :wink:

1 Like

Duly noted.

Actually doing it would’ve been nice, tho’ :unamused:

2 Likes