Cant get WiFi setup on Photon... node.js a no go also

So I used the mobile app with no luck, two different locations.
Next step was PC with node.js… Drivers installed fine, and connected with node.js from cmd. but during setup got [Error: Unable to obtain claim code]. This was also tried at home and office with same results.
I have a an old core that is not having any issues connecting to ether network.

whuz up with it?

Could you please update to 0.4.3 from the github release page and see if that resolves the issue? Thanks :smile:

I’ve been reading over all the steps to do a firmware update…
Is there an easier way to do this? This is insanely complected for me.

Eventually the particle CLI will support flashing the system modules (cc: @nexxy) which will make the process much simpler, but I’m afraid there’s no other option right now. Let us know which part are you having problems with and we will try to guide you forward.

Focusing on your original problem, please explain more how things are not working for you. You mentioned you were unable to setup using the mobile Apps. Which part didn’t work for you exactly? More details there would help us understand the problem better!

Cheers,
mat.

When using the App, I go to connect a core and enter my password. It spins for a while then shows “No Cores found”. I’ve done this with an Android phone and a iPhone both at my office wifi and home wifi with same results.

I got the particle cli installed and ran setup with the Photon plugged into USB.
It found the Photon “Photon-4NW5” but then threw a WiFi error. attached is a screen shot of the command line. Same result using multiple Wifi connections, also used my phone as a wifi hotspot and still same result.

I was able to update the firmware, I have attached a screen shot of the command line.
The App will still not work and the particle cli is still doing the same as above.
( side note, I pulled out my old Spark Core, factory reset it, and successfully used particle cli to connect it to my wifi. )

@nexxy - any thoughts on this? If I’m remembering correctly, hasn’t there has been some issue in the past with particle cli wifi setup on Windows that’s now resolved with the latest version?

@mdma, @tylerwp,

oh dear! Yes this does look like something that should have been fixed recently. DFU util itself should also work, but I’m not particularly familiar with how this operates on Windows. @BDub might be able to offer some insight there.

Ss for the CLI however, Windows support of the Wi-Fi based setup isn’t as good as it should be yet. In the mean time, you should still be able to complete a serial-based setup of the Wi-Fi via the particle serial wifi command. Try that and let me know how it works!

Just a quick question, are you using the new Particle app for Photons? https://itunes.apple.com/us/app/particle-build-photon-electron/id991459054?ls=1&mt=8

For reference: http://docs.particle.io/photon/start/

Thanks @BDub I missed that there was another App as I already had an App from my old Spark Core, good catch!, I installed it and it worked with no problem.
Also thank you @mdma and @nexxy I’ve learned a lot from you guys already!!
Now off to my Twitter Christmas Tree project :wink:

3 Likes