Latest "particle setup" not working

Until now I have had a CORE unit working and testing. It was set up and connected with an android wifi setup.

I have just had trouble setting up a new photon, so I went through the instructions on the github release page:

The local EASY method using Particle CLI

If you have the Particle CLI
 installed already, you can update it and then update your device with 
the following combined command. Make sure the device is in DFU mode and 

sudo npm update -g particle-cli && particle update (note: you can try without sudo first if you wish)

Of course nothing works as expected because I read a lot of other places that say not to set up node and npm using sudo.

So I went through the manual process of installing dfu-util 0.8.1
downloaded the photon1.bin photon2.bin, and (which i just found randomly in this forum, who knows if I was suppose to actually flash that)

The flashing all seemed to go ok. It is still booting up into listening mode since it has not received wifi credentials yet.

After the particle cli update, setup does not seem to be trying properly:

particle setup
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet. 

Both of those conditions are true. But the program just exits here with no error message.

Before updating the particle cli, I tried to connect the photon with the android app, as well as "particle setup"
It would give me serial errors, so I had to use

sudo chmod a+rw /dev/ttyACM0

Then it would give me an error about not getting the MAC from the device, which is when I updated the firmware manually.

Does particle setup require more root privileges than access to the serial port?


particle serial wifi
...asks me for the router info ...

    throw e;
Error: Invalid port specified: undefined
    at new SerialPort (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/serialport/serialport.js:134:13)
    at Object.extend.serialWifiConfig (/home/deadlock/local/lib/node_modules/particle-cli/commands/SerialCommand.js:471:39)
    at PromptUI.completed (/home/deadlock/local/lib/node_modules/particle-cli/commands/SerialCommand.js:379:9)
    at PromptUI.onCompletion (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/lib/ui/prompt.js:69:10)
    at AnonymousObserver.Rx.AnonymousObserver.AnonymousObserver.completed (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/node_modules/rx/dist/rx.js:1793:12)
    at AnonymousObserver.Rx.internals.AbstractObserver.AbstractObserver.onCompleted (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/node_modules/rx/dist/rx.js:1730:14)
    at AnonymousObserver.tryCatcher (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/node_modules/rx/dist/rx.js:567:29)
    at AutoDetachObserverPrototype.completed (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/node_modules/rx/dist/rx.js:5288:56)
    at AutoDetachObserver.Rx.internals.AbstractObserver.AbstractObserver.onCompleted (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/node_modules/rx/dist/rx.js:1730:14)
    at InnerObserver.onCompleted (/home/deadlock/local/lib/node_modules/particle-cli/node_modules/inquirer/node_modules/rx/dist/rx.js:3425:65)

Actually none of the particle-cli commands seem to be setting up the serial port properly anymore.

@cdeadlock we saw the issue. Going to rollback in a while. Give us a second :wink:

Alright simply do a npm update -g particle-cli for V1.6.8 and you are good to go! Sorry about that :slight_smile:

@cdeadlock can you re-install the CLI? This should be fixed now

1 Like

Ok, I am now able to setup the photon fully. Thanks

Is the android app not compatible with photon setup yet?

1 Like

Iā€™m having this exact same problem with latest particle-cli :worried: setup quits after protips

EDIT: using Kubuntu 16.04, 4.4.0-36-generic #55-Ubuntu SMP Thu Aug 11 18:01:55 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

EDIT2: particle setup wifi hangs after choosing the network, or right before that if I choose not to scan.

EDIT3: PROBLEM SOLVED. I connected the photon over usb and setup worked just fine.