Does Particle-CLI not yet support setup of Photon on Windows? [SOLVED]

The support docs indicate that you can set up Photon in a Windows PC with Particle-CLI:

However, when I do this with the latest npm version (1.5.11), I get an error:
! Woops. Something went wrong connecting to <photon>. Please manually re-connect to your Wi-Fi network

Adding extra logging to get the precise error message reveals this:
Unsupported platform. Don't know how to scan Wi-Fi on win32

So, is setting up a Photon on Windows via USB supported or not?

(In case it’s relevant, I’ve tried the Android app but can’t get it to work. My wireless requires a username/password, and the app only provides a field to supply a password. I’m investigating the USB connection to see if I can work around this)

I have gotten it to work in the past, but setup can be tricky at times. Did you have any problems installing the driver?

I believe that the drivers are installed correctly:

The device is found via USB, but particle setup goes like this:

> I have detected a Photon connected via USB.
? Would you like to continue with this one? Yes
! The Photon supports secure Wi-Fi setup. We'll try that first.

…and by try Wi-Fi first, it means try Wi-Fi only. Looking at the code, it appears that its failure to try USB after Wi-Fi is not an error. Setting up the Photon over USB simply not implemented in 1.5.11.

There are indications that WPA2 Enterprise has been a problem in the past:

Granted, that was written about the Core, and might not be true anymore for the Photon. Maybe somebody else can clarify?

Are you able to try particle serial setup?

How does it react to setup in manual mode?

I connected to a free, unsecured, captive portal-free Wi-Fi and had the same problem. But I need to connect to enterprise Wi-Fi in the end, as that is where the code will be developed and the device eventually deployed.

Doing particle serial setup only outputs the help info for the paticle serial command, indicating that it isn’t a recognized command:

c:\dev>particle serial setup
particle serial

    simple serial interface to your devices

    particle serial list  - Show devices connected via serial to your computer
    particle serial monitor - Connect and display messages from a device
    particle serial identify - Ask for and display device ID via serial
    particle serial wifi  - Configure Wi-Fi credentials over serial
    particle serial mac   - Ask for and display MAC address via serial

Also note that I had to modify the CLI library’s findDevices command, as the manufacturer for my Photon as found by the lib was Photon, not Spark, as the code expected.

Oh, sorry, that should have been particle serial wifi.

@aelr, as @dougal pointed out, neither the Core not the Photon support enterprise WiFi.

1 Like

It is true. On the Core with the cc3000, it was actually not possible. But the Photon’s broadcom/wiced chip does allow for enterprise support, so there’s at least the possibility for this in the future.


I was wondering if the BCM43362 supported it. I was trying to find the docs that laid out the chip features, but all I could find was the datasheet with the low-level functional/electrical specs. Thanks for clarifying, @christine.

Well, to close this out, @dougal your corrected command worked. I was able to get it working over wifi when connected to my PC. I can at least start developing with this for now and hope that someone endeavors on enterprise wifi support for the photon eventually.

Thanks all for the help!

1 Like

Since it’s supported by the chip, we can hope that it won’t be too hard to add support for it in the setup procedures, eventually.

It’s not supported at the chip level afaik, but in the wifi module firmware. WICED will be apparently released with Enterprise support at some point,that incudes updated firmware for the wifi module and hopefully a nice API for us to integrate, but this hasn’t happened yet.


trying to use the particle cli setup and i get this error after having connected to the photon on my usb port (com3).
it finds the Photon-waq6 and asks for my ssid and password. After entering this information… iget the list of possible security settings…I select WPA2 and hit enter…it goes on saying: “Obtaining device informations”

and it continues writing this essage on the cli output screen endlessly every 10 seconds to never return…

What can I do now???