Photon led d7 stuck high

Anyone know how to shut off led d7?

Rather short answer for a rather short question

digitalWrite(D7, LOW);

Thanks for the response ScruffR. Question was not well put. D7 is on at power up of photon. Reset/factory reset brings no change- condition returns. Not yet connected to WiFi but did get to name/name string stage of Particle app for iPad before the D7 issue set on. Also saw a WiFi listing in network on the iPad when name and name string were set -but now iPad can’t see the photon. Just installed particle CLI on win8 (old netbook) usb powers up, D7 still on no connection seen. Working on it.

Can you try Safe Mode and reflash a working firmware


particle flash --usb tinker


Have you seen this?

Ok. Photon in DFU mode via usb (win8) and D7 is steady blue. I am new to protoboards. I have Particle CLI successfully installed (win8) on netbook. Of course Node.js, and Python 3.4 are also. Tried Particle update * at cmd line; got “error trying to execute DFU Utilities…” Tried driver update in Device Manager (win8 sees Photon DFU Mode under Other devices) with extracted to Downloads, got “could not find driver software” from “locate manually.” Event properties for device config in viewer show drivername null and deviceupdated false (expected). Particle flash --usb tinker just got " no dfu device found. I have looked over a lot online, obviously complex-not what I thought it would be. Working on it. Thanks.

I know this is probably not the cause of the problem, but just in case because you never know, do you have any pins connected to D7 that might be high? If so you should try removing it because you can turn on the D7 LED by just bringing that pin high with an external connection.

1 Like

What do you mean by that?
There is no update command in CLI. Try particle help to see the possible options.(this was true for the previous version of CLI :blush:)

As for the DFU drivers, you could also try Zadig (select libusbK).
This used to be the way to install DFU drivers for the Core and should still work for the Photon.

1 Like

Thanks ScruffR. Following up on your suggestions a bit here. Back after a while.

Back working on this.
@cmd prompt ‘particle list’ returns photons name, device #, and ‘offline’ state.
@cmd prompt ‘particle update *’ returns ‘system firmware update successfully completed!’ Photon changed from dfu state to having RGB led solid green and D7 is still high.
@cmd prompt ‘particle flash --usb tinker’ returns 'File downloaded successfully
…Error writing firmware…Invalid DFU suffix signature…
Error during download get_status’
Again, Photon changed from dfu state to having RGB led solid green and D7 is still high.
Think windows 7 is set up correctly to work with photon-but the device will not go into listening mode.
So maybe I should check in with someone at particle support.
Thaks for any feedback.