Photon Installation - Windows 10 Driver - Other Driver Category Not Shown

The same problem happened to me as well! The serial port can not be opened normally in Windows 10.

I had problems with windows 10 tonight also… I found that I forced the driver install using pick from a list and the “have disk” feature… it then added a photon and listed it as not responding

but also added a serial port - I updated the driver and pointed to photon file and worked fine.

I think windows 10 may need a usb serial driver before you can install correctly.

that being said, I had issues using the particle CLI to setup and eventually gave up and used my fiancé’s iphone

1 Like

also you could try this tutorial!

How to Flash the Latest Firmware to Particle Photon using Windows:
http://blog.jongallant.com/2015/08/particle-photon-firmware-flash-windows.html

I just tried to install my Particle and had the same problem. Windows issues the familiar sound when the device is plugged in but there is no mention of Particle in Device Manager and no category of “Other Devices”

Joe

I’ve just gotten my Photon and am trying to follow the Getting Started guide. I am able to interact with the Photon via my phone, but when it came to installing the USB driver, the instructions fail because the device doesn’t show up under “Other devices” in the device manager (Windows 10). I tried holding down the Setup button until it was blinking blue and forcing a Scan for Hardware Changes, to no avail.

Can someone point me in the right direction?

Edit: This was the answer before above post was moved over here
Now it’s somewhat of a duplicate of Moors7’s answer further up

Does Windows give you the device connected sound once you put the device into Listening Mode?

If you hear it, have a look if Windows is scanning for known USB drivers.

Just at the off chance, have a look if your device already got recognized as COM device (or under any other section in DevMgr).

As others have pointed out above, make sure to look in the Ports (COM & LPT) section too

1 Like

Thanks for moving me into the correct thread; the answers provided here worked for me. Specifically, the Photon was showing up in the Ports group as a “USB Serial Device.” Once that was determined, the instructions worked great. Perhaps the Getting Started guide could be updated with this information?

1 Like

Thanks

Having worked through the tutorial by following the link, a new serial port has been added. But the CLI still can not work.

What do the device properties tell you about the yellow exclamation mark?

it said the driver of Photon(COM3) has been installed but can not be opened normally

hey joshua,

I believe that what you’re saying is correct.
Currently, we have only been able to setup a device with windows 10 using:
particle serial wifi
and getting the deviceID in advance to issue:
````particle device add deviceID``` once you’ve added the wifi credentials to it using the first step.

-Corey

Has anyone been able to get the photon working in Windows 10? I’ve tried everything listed above with no luck. In DFU mode it shows up under Other Devices. In listening mode I see it under Serial ports after I force the driver to install as a legacy device but I get an error 10 stating the device is not working correctly.

I also had the same problem with my windows 10 system and my photon;
as @smogs posted above, did the same to get my photon to appear.
after my photon was visible it worked fine.

Yes, I’ve got USB Serial for Core, Photon and Electron connected to Windows 10.

Once you find the device under “Other Devices” or “Ports” in DevMgr, you’ll need to update drivers by selecting driver (as shown in the docs)
https://docs.particle.io/guide/getting-started/connect/photon/#using-windows

Using these drivers
https://s3.amazonaws.com/spark-website/Particle.zip

3 Likes

And what do you do if it does not show up under “Other Devices” or “Ports”?

I changed USB cable and now it works. Thanks you guys.

I’m really disappointed and frustrated with using the Particle Photon on Windows 10. I’m trying to write a program in which I need to get sample values from the Photon over a serial connection, but I can’t even get the Photon driver installed. When I plug the photon in to my laptop’s USB port, I get a message “USB device not recognized. The last USB device you connected has malfunctioned and Windows does not recognize it” I have tried using several different cables (all of which work perfectly with other USB devices) and had one success using a USB 2.0 hub between the Photon and my computer. However that was short-lived as the error re-surfaced the first time I re-flashed my Photon while working on my project. After that I have not been able to get it working after multiple tries. After I get the message, I see the connected Photon listed only as an Unkown USB Device (Device Descriptor Request Failed), and I cannot update the driver for it or do anything to make it work as a port.

Have you got any chance to check if it’s a Win 10 or a hardware issue, like dual boot or another computer Win 7/8.1/Linux and try there.

I’ve seen a post where a user used zadig to install the UsbSer driver.

Try uninstalling the previously installed Particle Serial drivers as outlined here

Did you follow these steps?
https://docs.particle.io/guide/getting-started/connect/photon/#installing-the-particle-driver

I have the same problem on all my 3 photon boards. It recognize the hardware, but having problem creating a Comm port on windows 10. I will try to install the new driver tonight the one from ScruffR above…