Windows 10 - Photon Doesn't Show up in Device Manager (recent issue)


I’m having a recent issue where I can’t get any photons to show up in the device manager in Windows 10. I have recently had no issues with this - I pulled the MAC address off of 18 photons last week through Putty with no problem, and have had success with both my Windows 10 machines over the last year connecting via serial.

The issue started last week, and since I have tried multiple photon devices, multiple USB cables, and multiple Windows 10 computers and USB ports and cannot get them to show up even when clicking “show hidden devices” and scanning for hardware changes (I also don’t hear the chime sound that Windows makes when you plug in a USB device). I tried updating the drivers ( v ) which said drivers are no longer necessary to download for Win 10 and effectively erased the previous drivers from one of my computers - though I still have had no luck. Also, the photons I was working with were out of the box. I had the same issues after claiming them to my account, and flashing with 0.6.2 version firmware.

I’ve looked over a couple other threads about this issue, both of which were over a year old, but none of their solutions worked for me. Does anyone have suggestions for troubleshooting this? I can provide more information about the situation if necessary and will work on the issue more myself in the mean time.


Ping @rickkas7

With the Photon connected by USB, open the Device Manager. It should show up something like this:

Another useful thing to try is to put the Photon in DFU mode (blinking yellow) by holding down RESET and SETUP, releasing RESET and continuing to hold down SETUP while the status LED blinks magenta until it blinks yellow, then release.

Under Windows, DFU and serial modes use different device drivers, so it’s possible for one to work but not the other. This can help narrow down the possible reasons for failure. That should look like this in the device manager:



Thank you Rick!

It turns out the issue was the cables - I managed to order 20+ USB cables from Adafruit that were all DOA. Provided power to the photon, but no data connection. I figured at least one of the 5 or 6 I tried would have worked. A silly issue, but I’m glad it is resolved.

Lesson learned: you can’t trust USB cables, even if they are brand new.

Thanks again,