Photon Installation - Windows 10 Driver - Other Driver Category Not Shown

Hello Community,

Here’s some basic info:

  • I am attempting to install my Photon on Windows 10.
  • I have an appropriate USB cable with a data line
  • I Disabled Driver Signature Verification using the method here

Unfortunately, no “other devices” category shows up in my Device Manager.

Will someone please help me solve this issue?

Thank You

What does show up? Anything Spark/Particle related?


Hello Moors7, unfortunately, nothing shows up that is unusual - no unnamed devices.

1 Like

Could you try a different USB port/cable?


I have tried two cables, and both failed to appear.

That’s strange, there should be something to see in the device manager. Could you make a screenshot of it while the Photon is plugged in? Make sure to click the “scan for new hardware” button, just in case.

Could you check the “ports” tab, it might be in there. Also, does windows give any kind of indication something is happening when you plug in your photon? A sounds, a pop-up, anything?
Could you try checking the device manager when the photon is in listening mode (blinking blue), and perhaps even DFU mode (blinking yellow)? Either of those might help.

1 Like

Mine shows up under Ports (COM & LPT) like @Moors7 suggested. But if it isn’t anywhere to be found you can right click and choose “scan for hardware changes” and that might bring something up.

1 Like

the device should show up under the Ports/COMS tab like @Moors7 mentioned.

Also, if you update your particle-cli via npm install particle-cli -g should work. Once updated, using particle serial wifi you should be able to setup your device with that method.

To setup&claim with Windows10:

  1. plug in photon
  2. put in setup mode
  3. issue particle identify
  4. save the deviceID
  5. press reset on device
  6. issue particle serial wifi
  7. setup wifi for device
  8. after device is now connected to Wifi,
    issue particle device add deviceID
  9. after tha process, you should be good to go!


The same problem happened to me as well! The serial port can not be opened normally in Windows 10.

I had problems with windows 10 tonight also… I found that I forced the driver install using pick from a list and the “have disk” feature… it then added a photon and listed it as not responding

but also added a serial port - I updated the driver and pointed to photon file and worked fine.

I think windows 10 may need a usb serial driver before you can install correctly.

that being said, I had issues using the particle CLI to setup and eventually gave up and used my fiancé’s iphone

1 Like

also you could try this tutorial!

How to Flash the Latest Firmware to Particle Photon using Windows:

I just tried to install my Particle and had the same problem. Windows issues the familiar sound when the device is plugged in but there is no mention of Particle in Device Manager and no category of “Other Devices”


I’ve just gotten my Photon and am trying to follow the Getting Started guide. I am able to interact with the Photon via my phone, but when it came to installing the USB driver, the instructions fail because the device doesn’t show up under “Other devices” in the device manager (Windows 10). I tried holding down the Setup button until it was blinking blue and forcing a Scan for Hardware Changes, to no avail.

Can someone point me in the right direction?

Edit: This was the answer before above post was moved over here
Now it’s somewhat of a duplicate of Moors7’s answer further up

Does Windows give you the device connected sound once you put the device into Listening Mode?

If you hear it, have a look if Windows is scanning for known USB drivers.

Just at the off chance, have a look if your device already got recognized as COM device (or under any other section in DevMgr).

As others have pointed out above, make sure to look in the Ports (COM & LPT) section too

1 Like

Thanks for moving me into the correct thread; the answers provided here worked for me. Specifically, the Photon was showing up in the Ports group as a “USB Serial Device.” Once that was determined, the instructions worked great. Perhaps the Getting Started guide could be updated with this information?

1 Like


Having worked through the tutorial by following the link, a new serial port has been added. But the CLI still can not work.

What do the device properties tell you about the yellow exclamation mark?

it said the driver of Photon(COM3) has been installed but can not be opened normally