Win 10 no com port


So far I have been using the web interface to build and flash my Photon. I now need access to the serial port so I can do some debugging. I installed the particleCLI and and ran particle setup from cmd/powershell. I have also installed Particle Dev but I’m not seeing any Com Port in Device Manager. I also checked under “view -> Show Hidden Devices”.

A few days ago I re-installed my whole laptop and again installed the particleCLI, ran particle setup and also installed Particle Dev, but again I’m still not seeing a Com port?

I’ve read:
I’ve tried to install the particle drive but it says no installation is required on windows 10.
Using ZaDiag I see no devices
and I don’t see any Photon device under “USB Controllers” in Device Manager.

Anyone have any ideas here?

Are you using

  • a USB-Hub or
  • tested different USB-Ports like 2.0 (blue one) or 3.0 (red one) or
  • tested another Laptop (Windows or MacOS)?
  • Latest version CLI installed (npm install -g particle-cli)?
  • Could it be a problem with user rights management on your Windows (Standard or Admin-User)?
  • Gave TeraTerm a try?
  • Worked it before?

Prepare us with a screenshot from your DeviceManager, pls.
The Photon is blinking fine?