Photon serial port failing to appear on Windows 10

Tags: #<Tag:0x00007fe22618fde8>


I’m following the instructions in to set up socketcan with carloop and my Particle Photon. The instructions indicate that when I connect my photon to my laptop with a USB cable, I should see the device appear under Ports in Device Manager. However, I don’t see any Ports appear. I also don’t see the Photon appear under Universal Serial Bus Controllers.
The instructions indicate A serial port named /dev/ttyACM0 should now be available. Check with ls /dev/ttyACM*. However, when I try this command, I don’t see any ttyACM devices appear.
I’m running Windows 10 on a Surface Book.
My Particle Photon is connected to wifi, and when I try particle nyan from Particle CLI, I’m able to see the lights flash rainbow colors. However, it seems that the USB connection isn’t being recognized. particle serial identify returns Could not identify device: No serial port identified on my device CL, and within bash I get the error ! Theserialportdependency is missing or invalid. ! Please reinstall: Cannot find module '@serialport/bindings'
I’ve tried reinstalling particle-cli but I can’t seem to resolve this error.
Any additional troubleshooting tips you might recommend? I have two different Photons and I’ve hit this issue with both of them. I’m hoping to get the serial port to appear so that I can proceed with the steps in the linked tutorial.
Thanks in advance!!


Download the CLI installer from here and make sure to tick the “remove old drivers” checkbox

After that put your Photon in DFU Mode (blinking yellow) and run

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v

AFAICT this refers to Linux not Windows.


This is definitely a Linux command and will not work on Win10. You will need to reinstall as @ScruffR says above and then look in device manager under the USB section before you plug in the photon and then see what changes to find the port number it on. OR open a command prompt and enter

particle serial monitor --follow

once the photon is plugged in and it should show up looking like


Then just enter to select it, (or if there is only one found) it will automatically open a connection …


Mine is on a MAC but in windows you will see a com: port number instead of “/dev/tty…”


Thank you both for the tips! I’m running Ubuntu Bash on Windows (, so I assumed that the port should be visible there still. But maybe I should try installing an actual VM and see if it appears then.

I’ll also try the other steps you suggest and report back with a status update. Thanks again!


@kimkim, it would be a lot easier to run Particle CLI directly from Windows and installation is easy with the Windows CLI installer.


Ah, perhaps. However, I need to run in a Linux environment in order to get cansocket working. Thanks anyways :blush: