Having problems with photon not being able to flash code

I’ve been having an issue for the past two days with my photon not being recognized when connected through my usb port. The terminal outputs Unable to open USB device. I’ve tried booting the photon in DFU mode and successfully updating, but the terminal keeps outputting the same result. I tried flashing some good code on my photon and keep finding myself having the same problem, at this point I don’t know what else to try since I keep getting the same result

Hi @Alyx_Nasa

Thanks for letting us know. I understand that you are experiencing issues with connecting to or viewing your Serial port output.

An immediate check, if you have not already done so, is to try connecting the device to another computer and if the device can be detected.

If this does not work or if you like to know more, you can read more about Serial port connection for various OS here: About Serial | Tutorials | Particle

For Mac, to locate your serial port, you can also try ls /dev/tty.*

Are you using Windows 64 bit? We regret to inform that there are no 64 bit drivers for Windows 7. Serial connection is not possible.

If you are on other versions of Windows, please check the below guides:

Do let us know if you have more queries. You can also log a ticket at support.particle.io .