Photon No Serial Port Identified - please help

Dear community
I activated a Photon out of the box yesterday using the iPhone App. Claimed the device with no problems. The device came in version 0.5.5 from the factory. Device was being powered from a 5V source directly in a protoboard.

I flashed my application OTA successfully. I did not pay attention (my mistake) to the target OS for the application so it flashed with 1.0.1 as target. I usually follow the steps in moving to 0.7.0 first and then something above this. However, the app was flashed ok and the firmware went straight to 1.0.1. After that, no issues working with the device and testing my application.

However, after all the above, I connected the USB cable for the first time as I wanted to change the WiFi credentials but the device was not identified by the Terminal application ( I use MacBook Pro).

The “No Serial Port Identified” error showed in the terminal screen. I tried everything I could think of:

  • check different Particle USB cables. same errors
  • check the same cables with other photons and electrons and everything worked fine: cable ok, terminal app ok, Mac ok.
  • restarted the Mac. same errors.
  • particle usb list gives me: “No devices found.”
  • put the photon in listening mode (blinking blue) and tried particle serial identify, it gives me Could not identify device: No serial port identified
  • put photon in DFU mode (blinking yellow) to try to flash usb an application but the Terminal application says: !!! I was unable to detect any devices in DFU mode... Error writing firmware: No DFU device found
  • particle serial list gives me No devices available via serial
  • downgraded OTA firmware to 0.7.0. Same errors
  • downgraded OTA to 0.6.3. Same errors.
  • upgraded OTA to 0.7.0 again, reinstalling bootloader. Same thing. USB/serial does not seem to work.

I read similar threads already (mostly cable errors, or windows drivers issues), so I could not find a solution already posted.

Could this photon usb/serial be broken? Apart from that, the photon is usable: I can use OTA new firmware or application versions.
Thanks for the advice

by the way, the photon is being powered thru the same usb cable with no issues regarding power.

How do you do the up-/downgrading?
Can you use the -v (verbose) switch when flashing via DFU?

Hi @ScruffR
I am flashing over the air to do up/downgrading. I use the CLI from the Mac Terminal app via: particle flash device_name xxxx.bin .
The photon gives no access at all to serial/usb so I cannot do anything via DFU mode.

This may indicate that either the microUSB connector or the USB interface on the device could be damaged.
I guess this is a case for a support ticket

Thanks for the help!

Just found this thread…do you mind sharing what the outcome of this was, @fenriquez?

I just got a brand new Argon today and I’m having the same issue…absolutely no connectivity via USB. I haven’t tried a firmware OTA flash yet, but I’m about to.



Hi @MattG
The hardware was faulty so Particle replaced it after opening a support ticket with them.

I see. Glad to hear they helped out with it. I’m in contact with Customer Support now, so hopefully they’ll figure it out. Thanks so much for letting me know.