Photon is online but CLI claims no USB/serial connection

Hello,
I’m having a similar issue as described here:

and

My Issue:
MacBook-Pro-DN:~ Nik$ particle list
YYYY [XXXX] (Photon) is online
Functions:
int digitalread(String args)
int digitalwrite(String args)
int analogread(String args)
int analogwrite(String args)
MacBook-Pro-DN:~ Nik$ sudo particle serial list
No devices available via serial

None of the other serial commands find the photon.
No trouble flashing code, changing to listening mode or to safe mode, etc.
Only problem is in not being able to access serial port that my code uses.

Not sure how to fix it.

Do I have to get a new device?

Just checking to see if there is an easier solution or another previously discussed topic.

Regards,
Nik.

Place the Photon in Listening mode and try particle serial identify and see if it works.

If not, can you trying using another cable?

Thank you for your reply @kennethlimcp. I have pasted the result below after I flashed Photon with my firmware. It flashes and uploads the data (variable val) to the cloud which I have been able to access as well. However, particle serial identify gives me the same result. It just doesn’t detect the device. I have also tried coolTerm. I have tried one other USB cable to no avail. So, I thought it wasn’t a cable issue.
I have get a hold of some more cables tomorrow.

MacBook-Pro-DN:~ Nik$ particle list
YYYY [XXXX] (Photon) is online
Variables:
val (int32)
MacBook-Pro-DN:~ Nik$ particle serial identify

! serial: No devices available via serial
MacBook-Pro-DN:~ Nik$


Super weird. Can you place it in listening mode (blinking blue) and see if Coolterm lists it? Be sure to refresh the device list :wink:

@kennethlimcp. CoolTerm doesn’t show the device in even listening mode, just the bluetooth ones. I made a video but not sure how to attach it here.
This is so weird. It was working well last night. And today, when it got powered on today, flashed the firmware on power on and just didn’t detect the device on USB/serial port.

Yeah that’s puzzling. Most of the the time it is cable issue.

You were flashing via Web IDE?

Can you try - particle flash --usb tinker in DFU mode?

And, after that, check “particle serial identify” in DFU mode or listening mode?

Is there anyway to activate USB or serial port independent of Serial.begin(9600)?

FYI:
I haven’t changed the firmware since last night. Just powered the board this morning. Maybe flashed it a few times to debug. Put it in Safe Mode a couple of times but thats it.

Thats weird. This is the output in DFU Mode.

MacBook-Pro-DN:~ Nik$ particle flash --usb tinker
Apparently I didn’t find a DFU device? util said dfu-util 0.8

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2014 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to dfu-util@lists.gnumonks.org

Error writing firmware…no dfu device found.

MacBook-Pro-DN:~ Nik$

Can you try another USB port and use a data cable?

@kennethlimcp I tried a different cable again today. I have tried different ports too. So, in all, 4 cables, 3 connected to the Mac and 1 from an outlet.

In listening mode, should the photon be visible via the serial port directly? OR is some there some setup?
Since I had it working 2 days back, I didn’t think so, but just wondering if anything got reset or something.

@mavenik
Okay, I was having this same exact problem today and was unable to fix it using the other methods so I went and tried a few new things.
I had been using the Particle CLI as well and I believe that’s what had this problem occur because I tested all of my Photon’s and neither of them would display serial.
What worked for me was I went to the device manager (I am not sure if you are using windows, so I’m not sure what the equivalent is for you), and I uninstalled the drivers for the photon that had allowed me to use the CLI, and installed the original ones. After that it worked on the first try.
Hope this works for you.

@Leon Thank you for the suggestion, Leon. I uninstalled and installed particle-CLI. It still didn’t help.
I’m not sure how to uninstall the drivers that allow you to use CLI. I have a Mac.

Hi @mavenik

Have you tried a powered USB 2.0 hub between your MacBook and the Photon yet? Sometimes the serial ports don’t work on USB 3.0 capable ports without a USB 2.0 hub in between. It’s a long shot but worth a try.

1 Like

Thank you @bko. Couldn’t get hold of a USB 2.0 hub. Amazon lists it at $20.
Eventually, I will have to be able to access the serial port thru wifi too.
So, not sure if I want to order one.

Any other clues?

The issue is, it used to work and it is not now so the USB port should not be the issue. Can you use the same data cable with another device and see if your MAC detects it?

1 Like

Hi @kennethlimcp. While I try your suggestion, I also tried the following suggestion from the tech support to try the photon on a Windows machine.

          I followed this post to install the driver on Windows 7 machine. https://community.particle.io/t/installing-the-usb-driver-on-windows-serial-debugging/882    

I was able to see the Photon on COM3 in Device Manager. However when I wanted to flash code so I could see the data coming out on COM3, device manager wouldnt register the Photon (basically when I turn the device on in breathing cyan mode or in breathing magenta mode to flash code)

particle serial list works to list the device which didnt happen on the Mac
particle serial identify shows that there is a serial problem.

For both the commands, the MAc doesnt even detect the device on the serial port.

Attached a snapshot, if it helps.

I tried the same cable on a Bluetooth Speaker. It began charging the speaker.
It didn’t show up as a Serial port.

Ok so particle identify worked so the cable is working fine.

Can you use a serial terminal like Putty, place the Photon in Listening mode and hit v and paste the output here? Thanks!

I couldn’t find a putty for Mac. I thought Terminal did that for a Mac.
Are you suggesting I try this on Windows?

Oh no no opps. You can use Coolterm if you are on a Mac :wink: