Photon "Serial timed out" error (Windows 7 64-bit)

My photons just arrived today, and I was eager to try one out. I’m using a laptop running windows 7 (64-bit) that already had node.js installed (v0.12.4), so I just installed the driver and CLI (per Particle’s instructions). I was able to setup an account using particle setup and connect to my home WiFi using particle serial wifi, but as I started exploring the CLI I noticed that some commands fail. For example, attempting to run particle serial identify times out although the list command shows it is connected. Any idea what is wrong / what I’m doing wrong?

$ particle --version

$ particle serial list
Found 1 device connected via serial:
COM8 - Photon

$ particle serial identify

! serial: Serial timed out
Potentially unhandled rejection [2] Serial timed out (WARNING: non-Error used)

$ particle serial mac

! serial: Serial timed out
Potentially unhandled rejection [2] Serial timed out (WARNING: non-Error used)

The serial support that is present in the factory photons has some known issues. They can be mitigated to some degree by

1 connecting directly to the serial port using PuTTY
2 attaching the device to your PC via a USB hub can sometimes help

Once the photon connects to the cloud can receives an update, these serial issues disappear.

Alternatively, have you considered using the Mobile app to claim your device?

I have not yet tried out the mobile apps. Where can I find more information about connecting directly with a serial port terminal program / commands I can use therein?

1.) download Putty : . Putty settings :
a.) connection type : serial
b.) serial line : COM10 (it is depend on your port number)
c.) speed : 9600

2.) to check core id, press i
3.) to set WiFi, press w

1 Like

I was able to establish a serial connection, but no data was sent back / displayed in the terminal. I tried pressing the “setup” button (I had already set it up via the CLI as described in my original post) and got a message like the one shown in @fikri’s screenshot, but once I re-entered the passphrase I wasn’t able to send it more commands (like i).

How can I verify that it is connected (“cyan” ramp up/down LED pattern is being indicated by the multi-LED) to the Internet? Is there a way that I can view my registered devices? Particle Dashboard > Devices just says “Bummer! No devices are associated with this product.” for me right now.

Hello Jacob,

Were you able to get this fixed?

I was able to connect the Photon to my home network yesterday and it worked fine.

I would like to switch to a different unsecured network today and "particle serial identify"
times out with the message: “! serial: Serial timed out
Potentially unhandled rejection [2] Serial timed out (WARNING: non-Error used)”

I tried using putty but couldnt connect to the device there either.


I’m having the same issue with one of the Photon devices I ordered. I tried Putty and it didn’t work either.

Had this problem as well.

Just got my Photon and don’t have an iPhone or Android device to use the apps. Also, my Windows 10 (64-bit) PC is wired, so “particle setup” didn’t work for me. I successfully got my Photon online using “particle serial wifi” and setting it up wi-fi manually. It downloaded the firmware update (LED blinking magenta) and back online after rebooting. So far so good.

Tried to claim but “particle serial identify” was throwing the same error as above and PuTTY wasn’t echoing anything back either.

Turns out serial doesn’t seem to work if the Photon is online (LED breathing cyan). So I reset back to listening mode by holding SETUP for 3 seconds (LED blinking blue) and ran “particle serial identify” again. Bam! Device ID was echoed immediately.

I re-ran “particle serial wifi” and manually setup wi-fi again to get online, then went and claimed my Photon in Build.

Totally working now.

Hope this helps.

Thank you @slagomatic, I will try it.

No, either I’m doing something wrong or this is a bug. I was able to get it setup but had to use the mobile app to get it to register / be claimed. It said it had already been claimed, which was odd but perhaps the result of my previous failed attempts.

Even now, though I can see it registered online, can run the tinker example, and see the device with particle serial list, I still can’t use particle serial identify without running into problems. I suspect this is because I’ve been doing this on a Windows machine (don’t let the MinGW environment fool you).

$ particle serial list
Found 1 device connected via serial:
COM8 - Photon

$ particle serial identify

! serial: Serial timed out
Potentially unhandled rejection [2] Serial timed out (WARNING: non-Error used)

Yep, it does this indeed. I can confirm that.
Tip; (like @slagomatic stated above)
Get your photon into flashing blue (WiFi credentials erased)
Than config your WiFi through serial (particle serial WiFi)
It will tell you the Photon’s ID when connected.
Copy the ID and claim your Photon through HTTPS://

The serial also times out when you want to configure wifi if there is already a known config available

So, we could say its a bug :wink:

Please update your Photon firmware to the latest release before using serial on out-the-box Photons. There is a serial issue in manufacturing firmware - this is usually resolved via an OTA update.

(Connect to serial and press ‘v’ - if you don’t see anything output then an upgrade is needed.)

1 Like

I successfully updated the firmware to v0.4.4 (using duf-util) and could connect to the serial port (COM8) while in setup mode, press v and see system firmware version: 0.4.4 (similarly I could enter m for MAC and i for identify, I think). However, as soon as I load the tinker app from my phone that all stops working. Is this serial functionality only supposed to work in setup mode?

Yes. The serial functionality is part of setup mode. During setup mode, application code doesn’t run.

That explains so much, doh. What it doesn’t make clear to me though is why I had to use the smartphone app to get it to register. I have another Photon that I got in the same order and haven’t opened yet, so I think I’ll try setting up w/o a smartphone again when I open that one and will see how that goes.

So I just got around to playing with my 2 new photons, 6 in total now.

Same problem as original poster.

My solution:
Connect to USB
flash bios 0.4.4
hard reset the photon
claim with android x 2 (Had to select the devices twice)
Set wifi connection details
manually reset photon

it worked for both devices.