Windows 10, Photon not showing up in device manager

I have been trying to get the photon to show up in device manager but I have been unable to see it show up. The system doesn’t do the usual disconnect and connect sound effects and the “Universal Serial Bus controllers” drop down does not actually show a device show up either.

This photon I did have running fine on an old wifi radio but the new wifi radio using the same ssid and password did not seem to work for the photon (even after removing power and restarting, which worked for most of my devices on new radio install).

I have the device in listen mode and it is breathing blue to use the parlance of our times.

I did get wireless android configuration working once but have never been able to get the serial device to show up in windows. Any suggestions on how to get the device installed on windows 10. (I tried show hidden devices )


Have you tried a different cable? i have had a couple of duds, also try a different port on the computer, i have 3 that work and 1 that doesnt for some reason.

there is a section in the docs that has drivers that you require. I have mine working on windows 10 without issues


Thanks Hootie81, used the new long usb controller cable that came with an Xbox One. That cable works fine! Thanks for steering me in the right direction. Bunk cables…

Happy New Year.

1 Like

I am currently installing visual studio as the node.js serialport module requires the build tools to get it installed properly. The COM port shows up now and I am able to connect to the serial monitor and have seen some json go by. However, when I try using ParticleDev and Particle->“Setup Device’s Wifi” it just shows the video asking you to put the device in listening mode and a cancel button. Waiting for core…

I have tried pushing the reset and setup, even past 10 secs.
Any idea what I am missing?


is the device in listening mode flashing blue?

yes, it is flashing blue.

hrmmm when you say you saw some json go by? that sounds a little strange.

using putty if you open a serial terminal and push “w” does it ask for SSID?

I know nothing about ParticleDev, i haven’t used it myself. but i would try and see if it works with putty or even the arduino serial monitors first.

I still can’t get the ParticleDev to work for setting wifi connection parameters. I can still connect the serial monitor in it but I don’t see json go by, not really sure how I got the one small json object before, I was playing around with trying to “enter string to send” help/?/etc.

using your suggestion of putty I was able to connect to my particle and use the w command.
I followed the prompts and my device is online once again!

Is there a webpage that details the commands available via serial?
---- i liked the <3 from spark—
SSID: myssid
Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 3
Password: xxx
Thanks! Wait while I save those credentials…

Awesome. Now we’ll connect!

If you see a pulsing cyan light, your device
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit to debug.

Spark <3 you!

Thanks for helping me get the usb interface to work using putty.
I’m still gonna play with the node.js serial module…I’d like to get that working and I’m not sure why ParticleDev isn’t working…but at least I’m online again.


Its great you got it online, the main thing i wanted to check was the correct drivers were installed.

Good luck with the node.js module, that well above my pay grade!

Just to follow up, I tried to get Visual Studio 2015 to work for the nodejs serial module and could not get it to work. I installed Visual Studio 2010 and everything worked perfectly! I think the documentation should be updated to include a suggestion to install Visual Studio 2010, since it does not work without having that compiler installed. (serial module requires compiler toolchain)

The documentation I am referring to:

I am not sure if the community edition would suffice, but I would think so.
There’s more specific notes on the node-gyp page; apparently 2013 express is also supposed to work…

Anyways, just wanted to add this note for others that might also run into these problems.

@davehorner, thanks for the info :+1:

Just a question, have you confirmed that this is actually bound to VS2010 or rather a framework that is shipped with 2010 but not 2015?
Some programs require e.g. .NET 2.x or 3.x, but 2015 only ships with 4.x, but via Control Panel / Add Features this can be done without VS.

What version of 2015 did you try (Express, Community, Pro, Enterprise, …)?

To be quite honest, it is a bit of a mess.

Read somewhere that apparently node-gyp v2.0 is supposed to support 2015 better, but when I run npm -g ls --depth=0, I see that I’ve got node-gyp@3.2.1 installed…so…

I also attempted using the env vars,
adding the --msvs_version=2015
as well as setting the msvs_version via the config set, which by the way was still set to 2015 when I got it to build successfully after installing the 2010 toolchain.
npm config set msvs_version 2013

It’s true, windows users aren’t happy (this is where I read that 2.0 is supposed to support 2015 better)…

This document is supposed to help you get node-gyp installed with 2015…
Building using Node-GYP with Visual Studio Express 2015 on Windows 10 Pro x64

This definitely does not relate to the .net frameworks as this is for native C/C++ code toolchain.
However, reading the node-gyp page, you will find that there are a lot of other deps needed than just the VS2010 toolchain. I also installed python 2.7, the windows 7.1 SDK which apparently is required to get x64 modules working.

Now that I’ve got it working, I’m not sure what is the bare minimum needed to get things working…
I am running 2010 ultimate and 2015 enterprise.