Photon usb interface not enumerating on Windows 10

Recently I am not able to see my photon devices enumerating on the device manager under Windows 10. I have followed these instructions to remove all existing drivers however the problem still exists. After plugging in multiple photons there still is no recognition on the Device Manager of these photons being present.

What device OS have you got on your device?
Can you flash an application that explicitly calls Serial.begin() in setup()?

Hi ScruffR,
I was able to further debug this today and found that my desktop PC had a 4 port USB hub that was causing enumeration issues. I removed the 4 port hub and cabled directly up to the Photon and then after running the instructions to remove all existing drivers and rebooting the PC the Photon enumerated correctly and Windows 10 drivers installed automatically after that. Applications that I have with Serial prints did show up. I tried this on Photons that were version 0.4.9 (old stock) and a newer 0.7.0 version. Both worked correctly. I also followed the same driver removal procedure on another Windows 10 laptop machine that would not enumerate and after running the above application and rebooting it also successfully enumerated and was able to use serial prints. Not sure what caused the Photons to stop enumerating in last year or so but with the instructions referenced above all is well on my Windows 10 now.
Thanks for the quick response.

1 Like