Particle Photon2

Hi, I connect my particle photon 2 via usb to computer, then i downloaded particle app on my android device in order to set up and configure wifi and other stuff for set up.However, particle2 is not listed on my android device. I dont use antenna, but only micro usb connector to pc. Also i tried to make set up with, it found my device as P2 and paired, but page is not moved to other steps but only remained on the same page. I also tryied to set up via CLI of particle , however, i met with an erro that it is not possible to setup this device with particle-cli. Please provide me support to solve this situation. Thank you!

Log to your user account ( if no account create one)

You eill be able to setup your device from the console app.

I already tried , but it is unsuccessful. Then what is alternative solution?

Are you using a proper USB cable data/power capable.
Does your system recognise and add a com port in the Device Manager of Windows ?

yes, actualy, i use micro usb cable to connect to my pc. then via Linux os , then it recognized usb connection as particle p2 connection.

Verify if you have a new drive " lsblk "
if you have a new drive send your code to this new drive

what do you mean? I have lsblk, but then what i have to do? I dont have any code, i want to do just setup. Could you please explain in more detail and clear?

In the Particle Tinker APP for Android

My 2 Photon2 appear but are shown as an unknown devices.

But i can still control it
Using D7 i can control the Blue LED Low/High via the APP

in play store, there is no particle tinker ,there is only particle iot app, which i already tried.Lookup Tools | Tools | Particle here you mentioned some parameters, where can I get them to verify that those are for my device?

Identify device over USB

Your Particle device must be connected by USB to your computer and in listening mode (blinking dark blue). If it's in another mode, hold down MODE (SETUP on Photon) until the status LED blinks dark blue.

The identify tool only works on Chrome (version 89 or newer) on Windows 10, Mac, Linux, or Chromebook. If you are using a different browser, you can use the Particle CLI and the particle identify command instead.

Identify Device by USB

I created account on paticle cloud, the connected my device via usb to pc.After all , i see that it is not connected to cloud, hiowever, my particle photon is in listening mode, blinking blue color. I dont know what is the issue?

Did you set up your Wi-Fi credentials using or using the Particle CLI? That's the most common reason a Photon is still in listening mode (blinking dark blue).

Hi @rickkas7 ,

My device is particle photon 2. Then, i can not set up even wifi , because there are 2 options on, first: usb connection on whcih i use my device and pair it, then page throw an error that particle is not seeing my device as attached on image png. Furthermore, I choose monitor one , as a result it is not connecting to particle cloud. I also tried to connect via particle cli? It throws an erro that it can not setup my device. Could you please help to configure this device??

You cannot setup a Photon 2 with particle setup. Instead use particle serial wifi.

Also make sure your USB cable is a USB data cable and not a charging-only cable.

Thank @rickkas7 . My usb cable is this : (let me know if it is okey?) As well as I did particle cli wifi, it is refusing connect to wifi. what do you think about this?

OK, you're running Linux. The problem is that you need to install a udev role so non-root users can access the USB serial port.

particle usb configure

You may need to run that with sudo, and you may need to reboot afterwards.

thanks. I tried to do particle usb configure. particle usb command is not found. Then i tried to installed dev rools as you can see. but again error is as attached. Please let me know. I rebooted as well.

What version of node do you have installed? If you have v18 or later, you may be running into an issue where node serialport won't install. The best workaround is to use nvm or fnm to be able to quickly switch to node 16 if you need to use any of the USB serial commands in the particle CLI.