Particle Photon2

my version of node is v16.20.0.


Do you think that issue related to software, rather than cable?

Probably software.

You could try reinstalling the Particle CLI. This may correct the serialport dependency.

npm install -g particle-cli

Then try particle usb configure again. The missing udev rule will also affect dfu-util, and also dfu-util -l will only show a device if it's blinking yellow. You could try lsusb to see if Linux can see a device; that would also verify that it's not a cable problem.

Usb is found as image : particle photon 2


I re-run this command : npm install -g particle-cli.(without purging existing version, because i have no idea how to remove it from my machine.)

I run again particle usb configure. Error remains the same

You could try this to uninstall before reinstalling:

npm uninstall -g particle-cli

I did again. Error remains the same. Could we arrange one brief technical call for debugging and solving this problem. Let me know please thanks.

if it is not possible. How I am supposed to solve this issue? Can we continue to debug this issue?

I used: particle serial wifi, but I had to change permissions on the device:

sudo chmod 777 /dev/ttyACM0

777 is overkill but works.

I have a post on here somewhere outlining how I configured with "particle serial wifi"

Thanks @louyo . It works now

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.