Introducing the Particle Firmware Manager

Hey everyone! Here’s a new tool to play with! :smiley: :hammer:

It’s the Particle Firmware Manager - a GUI tool to flash the latest system firmware to your Electron/Photon without needing to install the CLI.

I’ll leave the introduction short - you can find more details in the firmware manager documentation.

Please take it for a spin and let us know how it goes! :smile:

17 Likes

Nice.

For all those interested in trying out the tool, please let us know if you encounter any issues by posting here in this thread or by creating an issue on the Issues page in the Github repository for Firmware Manager.

I think it tried to reboot my windoze box without asking after installing maybe 4 drivers.

Displayed a window with no content, asked for escalation to admin, then asked for permission to install maybe 4 drivers, so far so good - albeit a bit crude.

I was doing something else then suddenly realised the machine was trying to reboot, without asking first.

Is that part of the install (at least on Win 7 sp1 64-bit) ? If so, I do not appreciate that at all, had plenty of real-work windows and documents open, and was only saved by a series of dialog boxes from each app that had unsaved data - many other apps did close, including things that I needed.

Please modify that behaviour.

Hi, tried on osx, and worked perfectly, great job.
Could this also be a way of trying out the development train?
thanks

1 Like

Yikes! That’s no good. Thanks for the feedback, Andy! Will look into it.

Thanks, Andy, I’ve never seen anything like that - we don’t need to reboot to install drivers.

I’d been testing on Windows 8.1 and Windows 10…I just tried Windows 7 and the experience was far from as polished.

I’ll add a “Installing drivers…” to the blank page on startup and the particle logo. It might be my machine, but installing drivers took a long time, with 4 popups, yet on Windows 8 (running as a VM on OSX) it’s much quicker and with only the one popup asking for admin access.

After installing the drivers, the system did not try to reboot. I’m not sure why that happened to you Andy, there’s no reboot calls in the driver installer as far as I know.

1 Like

OK - as long as we’re not initiating a reboot, that’s all we can do.

I can confirm that the individual driver install did take a long while, and made the blank screen all the more blatent. But again, that’s likely beyond your control.

I’m OK putting the reboot down to factors beyond your control.

Thanks for testing this.

Not to say this is what happened, but this is a pet peeve of mine: While you are typing for whatever reason, if a dialog box comes up asking you to do something, e.g., “Would you like to reboot?” the typing can instantly accept/cancel the dialog. It’s quite annoying. Could something like that have happened?

Nope - I was talking to a colleague when I saw the screen change out the corner of my eye.

Ok cool, that was worth a shot… I don’t really hope to solve this as it could be any number of things, but do you have automatic updates enabled? Also, by any chance would you be willing to try and get it to repeat itself? Completely remove the drivers, and there is a registry setting you’d have to delete to make it clean again.

HKLM\SOFTWARE\WOW6432Node\Particle\drivers\serial\ (64-bit)
or
HKLM\SOFTWARE\Particle\drivers\serial\ (32-bit)

Sorry guys, got another (minor) failure mode.

The first time I connected an electron and used the updater, it looks like the updater tried to run before the device drivers had completely installed.

I hit the big blue button, and then not a lot happened - no change on the LED on the electron, no progress bar. After a while I got the bad message:

Then a few seconds later, I got the “your device is ready to use” or “device installation complete” message in the toolbar. So it looks like the app keys off something other than the device driver being installed and ready to use.
This is the Win Pro 7 sp1 laptop, and first time driver installs can take a long while.

FWIW, I updated at least 3 Photons yesterday and an Electron using the tool on a Mac (10.11.5) without issue.

Does it cater for Cores as well? I realise/see you didn’t specifically mention them in your post but I know that doesn’t necessarily mean you’ve forgotten the Core.

Cheers!

It won’t, since that wouldn’t make sense. With the Photon and Electron the system firmware is separate from the user firmware, with the Core this is one single thing. If you flash a Core, you’re including the system firmware, which is why flashing a core takes that much longer to flash than a Photon or Electron since they only get the use firmware.
Does that make sense?

1 Like

This is great! It looks like it only updates to the most recent firmware version - are there any plans to let you choose which version to flash (to allow previous firmware versions)?

It rebooted my W10 PC. The Update gauge line got about half way across then reboot. Happened twice and I gave up.

Thanks for reporting this - I must admit, I’m completely at a loss for why it would be rebooting. There’s no instruction to reboot, especially during the firmware update. (Any reboot commands would presumably come from driver installation.)

Any further details you can provide to help us replicate the behavior very welcomed. (We have tested Win10, both32 and 64 bit and not seen these reboots.)

Does this updater work with P1s? Is there any particular mode they need to be in? DFU, listening, standard running?