Electron wont connect to the cloud - never ending green blink


#21

We’re able to verify whether or not SIMs are stuck in TEST mode-- @Avalon, if you PM me your ICCID I can check it out for you.


#22

I did send mine, please have a look.

Thanks


#23

@will I’ve sent my ICCID for you to look, thank you! Awaiting your response.

@sbright33 I tried it, but this wasn’t the case, unfortunately.

@TheYoungSoul What’s the indication the SIM is stuck in TEST mode? I saw your topic and I believe I have the same issue as you.


#24

One of the particle engineers looked into and informed me that he believed it was stuck in TEST mode. Beyond the flashing green light, I dont think there is anything obvious that us end users can determine ‘stuck in TEST mode’. The engineer looked at my logs and that was his conclusion.


#25

Hey @Avalon – I checked, and your SIM is currently in test mode. However, that does not necessarily indicate that the SIM is stuck in test mode. Every SIM starts in this state and transitions to an active “production” mode after it has consumed 20KB of data (included for free in addition to your 1MB plan). If your device has never successfully connected to the Internet for any reason, your SIM would still be in test mode.

We can use the device logs from your Electron to be certain. Have you already flashed the debug firmware?


E-Series - Blinking Green
#26

Hi @will. Yes, I flashed the debug firmware a few days ago and have a log saved here, I’ll send it to you through PM. I couldn’t claim my Electron since it arrived, so yeah, I guess it has never connected to the Internet.

Thank you for your support so far.


#27

I am having a similar issue with connectivity in Nigeria. @mattcremerband and @Devin, were either of you able to resolve this problem in South Africa?

I have two electrons, one 2G and one 3G U270, both of which connected once to the cloud but afterwards have spent many hours blinking green in various locations around Lagos. The coverage should be fine as my AirTel 3G mobile hotspot gets full reception.

Was there a fix for you to get the Particle SIM working or was it easier to go with a 3rd party SIM?

Thanks for any help!


#28

Hi @cstites

Unfortunately I never got the Particle SIM working, and ended up going with a local option (MTN) which works great with the exception of one issue, the non-particle SIM seems to disconnect after about 60sec of inactivity, after which it does not automatically reconnect unless the device is restarted. For now I’ve gotten around this by pinging the API every 30sec or so, not ideal, but it works for me for now.


#29

The Particle.keepAlive() function may be helpful for 3rd party SIM cards. It specifies how often a UDP packet should be sent by the cloud code to keep the connection alive.
https://docs.particle.io/reference/firmware/electron/#particle-keepalive-


#30

I wasnt able to get the sims working either.

I got a 3rd party sim and it works well. It also works out a lot cheaper for me.

@mattcremerband check out afrihost sims. its on the mtn network but its R49 for 500mb and the data lasts a year. I havent had any disconnection issues and Ive tested it while driving around most of jhb


#31

Hey all, thanks for your recommendation for 3rd party SIMs, I managed to get a few and am now back in Lagos testing. So far I have had reliable connections with a global SIM but am also experiencing the same ~60 second timeout if the cloud connection isn’t active. Haven’t tried to implement a shorter keepAlive interval yet but will report back on that when I get a chance over the next few days.

I’m still trying to track down the exact issue with the Particle SIMs and took at look at the logs from tinker-with-debugging. As shown in the logs snippet below, it looks to me like there’s a Modem command being called every 15 seconds or so for AT+CGREG? that returns values of “2,3”. This is all within the [Modem : :Register ] section.

     2.072 AT send      10 "AT+CREG?\r\n"
     2.082 AT read  +   14 "\r\n+CREG: 2,3\r\n"
     2.092 AT read OK    6 "\r\nOK\r\n"
     2.092 AT send      11 "AT+CGREG?\r\n"
     2.102 AT read  +   15 "\r\n+CGREG: 2,3\r\n"
     2.112 AT read OK    6 "\r\nOK\r\n"
    17.112 AT send      10 "AT+CREG?\r\n"
    18.912 AT read  +   14 "\r\n+CREG: 2,3\r\n"
    18.922 AT read OK    6 "\r\nOK\r\n"
    18.922 AT send      11 "AT+CGREG?\r\n"
    18.932 AT read  +   15 "\r\n+CGREG: 2,3\r\n"
    18.942 AT read OK    6 "\r\nOK\r\n"
    33.942 AT send      10 "AT+CREG?\r\n"
    35.562 AT read  +   14 "\r\n+CREG: 2,3\r\n"
    35.572 AT read OK    6 "\r\nOK\r\n"
    35.572 AT send      11 "AT+CGREG?\r\n"
    35.582 AT read  +   15 "\r\n+CGREG: 2,3\r\n"
    35.592 AT read OK    6 "\r\nOK\r\n"

I found the ublox command reference here and found that the second parameter returning “3” indicates that the GPRS network registration was denied. (page 347) At this point I’m way out of my depth with the cellular network stuff so I am hoping someone else might be able to jump in with any ideas as to what the cause of this could be. I have more extended logs and also the full output from a successful connection on this network that I could sanitize and post if it would help anyone troubleshoot this.


#32

The short 30 second interval Particle.keepAlive(30); seems to also be required for AT&T SIMs that I’ve tried, just an FYI :wink:


#33

My Electron blinks blue forever unless I press the reset button. This happens whenever I totally remove power from the Electron. When I restore power to it, it blinks green for about 5 mins and then blinks blue forever unless I press the reset button after which it connects by breathing cyan in less than 1 minutes.

I’m using a 3rd party SIM, I will really appreciate suggestions on how I can resolve this issue, without the need to press the reset button.


#34

@Donwhale No luck with Particle.keepAlive(30); ?


#35

Thanks @mattcremerband, I found out the issue isn’t about keepAlive, it was not connecting because I didn’t connect the LiPo Battery.

In the first instance, the Electron was connected to the Control Everything Relay board which uses 12V power supply and powers the Electron with 5V through the Vin Pin. The Electron doesn’t connect to the Tower from cold-start unless I press the reset button.

I also used a breadboard 5V power supply through Vin, it wasn’t connecting either. I was thinking these boards should have enough juice to power the electron without the need for battery, but it seems I was dead wrong. Though I don’t know what the supply current of these boards are in order to make an informed decision.


#36

In that case it’s not the max. supply current that counts but the capability to cope with rapid peaks in demand and deliver the power fast.
Adding some caps might help there.


#37

@ScruffR, nice thought. I will try that out, as I’m actually designing a system that will not require the LiPo battery - elimination of the need to change batteries every few months.


#38

Check the specs on that 5V output, it needs to be 5V @ 2A and @ScruffR is right about adding capacitance at the VIN pin to help absorb transients created when the modem draws peak currents. Start with 470uF and go up or down from there.


#39

Can anyone help me get this darn electron online? I have tried for the last 2 hours with both a Particle SIM and 3rd party SIM using the start guide with no luck, just constant blinking green light.

With Particle SIM:

   311.736 AT send      10 "AT+CREG?\r\n"
   311.750 AT read  +   14 "\r\n+CREG: 2,0\r\n"
   311.765 AT read OK    6 "\r\nOK\r\n"
   311.769 AT send      11 "AT+CGREG?\r\n"
   311.783 AT read  +   15 "\r\n+CGREG: 2,0\r\n"
   311.798 AT read OK    6 "\r\nOK\r\n"
   326.802 AT send      10 "AT+CREG?\r\n"
   328.596 AT read  +   14 "\r\n+CREG: 2,0\r\n"
   328.611 AT read OK    6 "\r\nOK\r\n"
   328.615 AT send      11 "AT+CGREG?\r\n"
   328.629 AT read  +   15 "\r\n+CGREG: 2,0\r\n"
   328.644 AT read OK    6 "\r\nOK\r\n"
   343.648 AT send      10 "AT+CREG?\r\n"
   345.442 AT read  +   14 "\r\n+CREG: 2,0\r\n"
   345.457 AT read OK    6 "\r\nOK\r\n"

With 3rd party SIM:

   102.818 AT send      10 "AT+CREG?\r\n"
   104.612 AT read  +   14 "\r\n+CREG: 2,2\r\n"
   104.627 AT read OK    6 "\r\nOK\r\n"
   104.631 AT send      11 "AT+CGREG?\r\n"
   104.645 AT read  +   15 "\r\n+CGREG: 2,2\r\n"
   104.660 AT read OK    6 "\r\nOK\r\n"
   119.664 AT send      10 "AT+CREG?\r\n"
   121.458 AT read  +   14 "\r\n+CREG: 2,2\r\n"
   121.473 AT read OK    6 "\r\nOK\r\n"
   121.477 AT send      11 "AT+CGREG?\r\n"
   121.491 AT read  +   15 "\r\n+CGREG: 2,2\r\n"
   121.506 AT read OK    6 "\r\nOK\r\n"

#40

I’m sorry, but that’s such a vague question. There are hundreds of variables that could affect your setup. You might want to post a picture of your setup and show us some code. @rickkas7 might be able to interpret the log output you posted better. He also has a GitHub repository with some diagnostic code you could run.