Particle Electron won't connect to cloud


#1

I’ve recently purchased a Particle Electron and I’m currently unable to get it to connect to the cloud with the SIM card that came with it, it just keeps blinking green and won’t budge at all. I’ve noticed that it won’t work either with another 3rd party SIM from the carrier that seems to be the one you guys work with here in Brazil (VIVO). When trying to use a SIM from another carrier (TIM), it worked almost instantly. I’ve also tried to flash a different firmware with the APN settings for it to no avail. Any ideas on what might be the issue?


#2

One day I just couldn’t get the Electron to connect at all, then I noticed the antenna cable end had swiveled on the socket and come in contact with the metal of the microprocessor housing. I moved it away and was able to connect right away.

I don’t have an electronics background, so I don’t know if that was the actual cause or I just had a lucky coincidence, but now I pay attention to the antenna wire orientation out of habit


#3

You should submit a support ticket with:

  • The ICCID of your Particle SIM card
  • The Device ID of the Electron
  • The model of the Electron. It’s printed on the white label on the cellular modem module and is one of: SARA-G350, SARA-U260, or SARA-U270.
  • The country your are connecting from

The easiest way to get the first two is to use the Particle CLI. Connect the Electron to your computer, hold down the MODE button until the status LED blinks dark blue, then enter this command in a command prompt or terminal window:

particle identify

#4

@thresholdengineering
Sadly it’s not our case, since it does work with another SIM card.

@rickkas7
Done, thanks for the tip.