Electron wont connect to the cloud - never ending green blink


#1

Hi guys

I am unable to get my electron to connect to the cloud. Once turned on, the led blinks green for ever. (longest i’ve waited was 2 hours)

My Electron is compatible with the cellular network
Antenna is connected
Battery connected
Sim is activated
Cellular coverage and reception is good
Data limit fine
Tried cold booting
Particle’s mobile carriers seem fine

System firmware version is 0.4.8

I have done a particle update and also tried reloading the tinker app.
I have tried troubleshooting the keys as well.

Any other suggestion for me would be greatly appreciated.


E-Series - Blinking Green
#2

Can you try booting up in Safe mode?


#3

I’ve tried getting into safe mode, however when I get a blinking magenta and I release the mode button, the device seems to revert back to blinking green.


#4

Have you gone through the whole procedure here too?
https://setup.particle.io


#5

Not the whole process no, I went as far as I could though.
Registered my ICCID, setup billing, and then waited for the device to connect, to no avail.


#6

Ok, I’ve abandoned the particle SIM cards and gone with a 3rd party option and managed to setup my Electron successfully.

I’m guessing there’s an issue with the particle SIM on the South African network, or something like that.


#7

Maybe something for @will to answer


#8

Hey @mattcremerband

Would you be willing to PM me your Electron model number (G350/U260/U270), device ID, ICCID, and the city that you’re trying to connect from? I’ll do some investigative work on our end.


#9

Hey Matt,

I’m also in RSA and have had the same issue for the past week.

I’ve been wondering if it has anything to do with RICA

Looks like I’ll need too get my own sim too


#10

Hey Devin

While it sucks that you’re also not connected, I’m glad to see I’m not the only one. Fortunately we have a SIM that we took out of a 3G dongle.

If you’ve got decent MTN connectivity in the area checkout Afrihost’s mobile data packages. You can get 250MB for R29pm.


#11

@Devin would you PM me all of the same information also? I want to confirm that this is an isolated issue and not an issue with Particle SIMs in RSA.


Electron - Flashing Green with errors: CSD / PSD Registration Denied
#12

Hey @Devin and @mattcremerband – one additional piece of information that would be helpful is if you’d be willing to provide your firmware debug logs to us. This will give us the best information to know what is going on behind the scenes with the Electron is booting up:

To enable debugging you can download a version of Tinker that has USB serial debugging enabled:
https://github.com/spark/firmware/releases/download/v0.4.8-rc.6/tinker-usb-debugging-v0.4.8-rc.6-electron.bin

Then you can flash this to your electron with the Particle CLI with your electron in DFU mode:

particle flash --usb tinker-usb-debugging-v0.4.8-rc.6-electron.bin

Be ready to open a serial terminal with the CLI:

particle serial monitor

Now completely disconnect power and re-apply it (or Soft Power Down the electron by double tapping the MODE button, and RESET to power back up). This will ensure a full connection to the tower so we can see all of the little details.

Now open the serial terminal just after the electron boots. It should look similar to this if you catch it right at the beginning:

[ Modem::powerOn ] = = = = = = = = = = = = = =
     1.426 AT send       4 "AT\r\n"
     2.749 AT send       4 "AT\r\n"
     4.072 AT send       4 "AT\r\n"
     4.085 AT read UNK   3 "AT\r"
     4.098 AT read OK    6 "\r\nOK\r\n"
     4.102 AT send       7 "AT E0\r\n"
     4.116 AT read UNK   6 "AT E0\r"
     4.130 AT read OK    6 "\r\nOK\r\n"
     4.134 AT send      11 "AT+CMEE=2\r\n"
     4.148 AT read OK    6 "\r\nOK\r\n"
     4.152 AT send      19 "AT+CMER=1,0,0,2,1\r\n"
     4.167 AT read OK    6 "\r\nOK\r\n"
     4.171 AT send      15 "AT+IPR=115200\r\n"
     4.186 AT read OK    6 "\r\nOK\r\n"
     4.290 AT send      10 "AT+CPIN?\r\n"
     4.304 AT read ERR  37 "\r\n+CME ERROR: operation not allowed\r\n"
     5.311 AT send      10 "AT+CPIN?\r\n"
     5.325 AT read  +   16 "\r\n+CPIN: READY\r\n"
     5.340 AT read OK    6 "\r\nOK\r\n"

[ Modem::init ] = = = = = = = = = = = = = = =
     5.349 AT send       9 "AT+CGSN\r\n"

If you can copy and paste the output over the course of 3 minutes, that would be helpful. Please put this in a TXT file and attach it to the email reply. Thanks!

After we are done with inspecting logs on your Electron, please remember to disable logs with this CLI command (device in DFU mode):

particle flash --usb tinker

Electron flashes green forever
#13

Hi @will

I too am having trouble with an Electron stuck in flashing green. I have two Electrons and one can connect so I am pretty sure it is not a cellular coverage issue.

For the electron that is stuck in green flashing, I did go through the setup and I did download a simple program so it was connected at one point.

I followed your instructions for collecting the debug output and I was wondering if I could send it to you in the hopes you might be able to help me get this device connected. If there is a better place to submit this request please just let me know.

Thank you


#14

Hey @TheYoungSoul – Definitely. You can paste your device logs here and/or head over to our Support Portal and write to us via email. If you send us and email, please reference this support thread and attach the debug logs that you captured to the ticket.


#15

Thank you very much. I just sent in an email referencing this thread along with the log details. If you need anything please just let me know.


#16

Thanks!


#17

Hi there, I am having the same issue here in Switzerland. I managed to activate the Electron but now the LED is blinking green forever. Already tried all the steps suggested in the troubleshooting guide (except using a different SIM). No luck Any ideas? Thanks!


#18

I’m having this issue too. I couldn’t activate my Electron, only the Particle SIM card via the Setup web tutorial. I’ve read some forum posts with others having the same issue, but none with a solution. Should I follow [your instructions][1][1]: Electron wont connect to the cloud - never ending green blink @will? I did everything until the firmware flashing part. Thanks in advance for any reply.


#19

In talking with a couple of people from Particle.io, they believe my SIM is stuck in TEST mode. Their suggestion was to request a new SIM card as the quickest way to get it resolved. I have a made that request and I am waiting to hear back now.


#20

Mine has been stuck blinking green for hours. The solution was to move it where the signal is even stronger without interference. Inside I get 4 bars normally, when I press mode. Outside 5 bars. That solved it.