Cannot connect to the cloud, 3rd party SIM (vodafone) [SOLVED]


We just received our 3 particle Electron devices and tried two devices so far. However both are not working on a 3rd party vodafone sim card.

  1. We tried the steps and gave the APN:, and uploaded it successfully with particle cli under Ubuntu. Keeps blinking cyan also after power cycle both USB and battery

  2. Use the setcreds.ino option, uploaded successfully:

    #include "cellular_hal.h"
    STARTUP(cellular_credentials_set(“”, “vodafone”, “vodafone”, NULL));

void setup() {


 void loop() {
 // your loop code
  1. Updated the firmware to 0.5.1 and flash succesfully the electron-troubleshooting-v0.5.1.bin. Was able to get ICCID and SIM number. Not able to power on modem: “Turning on the modem: Error Failure powering on the modem”. However scanning for operators just works fine. Connecting with command D does not work.

So far no luck to get a connection. Hope somebody has some tips to get it working. We have tried out already two devices but gave no result. The sim card is working with internet in a iPhone 5.

Who can help?


Also tried now at different locations (cities) in the Netherlands. No luck so far. What I found strange is that it is still not capable of turning on the modem.

pinging @BDub to see if he has any inputs here!

This problem was solved in this thread: