Cant claim new Electron

Hi All,

I’m been trying to claim my second electron for the last day or so and I’m having no luck.

I’m using a 3P sim (Three.co.uk in the UK), I’ve downloaded the custom firmware including the correct APN settings for the carrier, flashed the electron via serial and I get breathing cyan so it seems to be happy and connected to particle’s servers. However when I progress on to the next set of the setup process (via setup.particle.io) it fails with
’ Setup was unsuccessful
Your Electron failed to connect to the Particle cloud.’

Before posting this I decided to take the hit and setup the M2M sim that came with the device (I only as hit because I’m only paying Three.co.uk 1p per MB here in the UK :D) however when trying to activate the sim via the same service its fails with a 504 gateway time out! (not really a problem for me as I’m planning on using my own sim but may be something others are seeing too?)

Anyone else had any issues setting up / claiming their electrons? The first one I did worked first time but this one just doesn’t want to play!

Thanks,

John

There is an issue setting up new Particle SIM cards right now.

Update - In addition to the data sync issues, our telephony partner is now having issues with their apis that let us provision new SIM cards, or deactivate existing SIMs.
Just to reiterate, SIM and cloud connectivity is working fine, but we can’t set up new SIMs right now.
Aug 26, 23:38 CDT

http://status.particle.io

That being said, I think you should be able to claim an Electron with a 3rd party SIM with firmware that sets the APN using the CLI.

If you haven’t already done so, install the [Particle CLI] (https://particle.io/cli).

Hold down the MODE button until the LED blinks blue. Then issue the command:

particle identify

Save the device ID that is returned; you will need that next.

Reset the Electron and wait for it to get to breathing cyan. Then issue the command:

particle device add YOUR_DEVICE_ID

Your new Electron should now show up in https://build.particle.io and https://console.particle.io.

2 Likes

Thanks @rickkas7 I had tried particle identify before but it failed, I didn’t realise that the device had to be in listening mode.

The above instructions worked perfectly, thanks for you help :smiley:

John

2 Likes

Hi, I’m running the device add command with an e-series evaluation kit, but get a “Failed to claim device: device not found error”

I can see the SIM is activated in my console and is consuming data, but device is stuck on rapid blinking cyan.

Also, ran particle keys server and particle keys doctor, but still can’t connect.

Any thoughts?

Thanks!