[Solved] Electron blinking cyan - SIM problem?


#1

I’m having a problem with Particle Electron.

The whole story goes like this:
I bought Electron about a year ago. I tried it. It worked fine. Connected to cloud - I had some fun with the Tinker app, but didn’t hava a particular project on hand, so the Electron was not used (not powered) for about a year.

Last week I started preparing for a new project which cannot use Wifi for connectivity and so I plugged the battery in to the Electron, and Electron to USB power source. After the normal procedure - the Electron connected to Cloud. I tried the “ping” widget in console and it was ok. I left it like that for some time to give the battery time to recharge… and here comes the problem.

When I got back to it, the Electron was repeating this pattern: blinking Cyan (like in Connecting to Cloud) for about 30 sec and afterwards some green blinking (repeat).

What I tried:

  1. Setting up the card once more (didn’t help and the setup told me that the card is already activated).
  2. Running the doctor in CLI. (didn’t help)
  3. Powering the Electron in different place with better 3G reception (thought about GSM reception)
  4. Updating the firmware from 0.4.8 to the newest.
  5. Checking this forum for similar problems (investigating the orange burst)
  6. Changing the power source to a huge one to eliminate the problem with lack of sufficient power
  7. Checking my balance and data usage (everything paid and no data used at all)
  8. Checking the SIM card for any visible errors/scratches etc.
  9. Checking the antena for connection
  10. Using a 3rd party SIM ---- WORKED

Hmmm… that is strange I thought. So I run a bit of tests and found a reliable repeating pattern. My code (but the same happens with “out of the box” Tinker) works like a charm with my 3rd party SIM and it doesn’t with Particle SIM.
Of course when I have my 3rd party sim, I also have to set up the APN which for my country (Poland) and my provider of the sim is “internet”. When I make the same test with original SIM I “comment out” the line: STARTUP(cellular_credentials_set("internet", "", "", NULL));

For the sake of transparency here goes my code(even though I checked with Tinker app and the problem stays):

// This #include statement was automatically added by the Particle IDE.
#include <Adafruit_DHT.h>

STARTUP(cellular_credentials_set("internet", "", "", NULL));

#define DHTPIN 1     // what pin we're connected to

// Uncomment whatever type you're using!
#define DHTTYPE DHT11		// DHT 11 
//#define DHTTYPE DHT22		// DHT 22 (AM2302)
//#define DHTTYPE DHT21		// DHT 21 (AM2301)

FuelGauge fuel;
DHT dht(DHTPIN, DHTTYPE);

void setup() {

pinMode(D0, OUTPUT); // Vcc dla DHT11
digitalWrite(D0, HIGH);

pinMode(D2, OUTPUT); // GND dla DHT11
digitalWrite(D2, LOW);

pinMode(D3, INPUT_PULLUP);

	dht.begin(); // Data z DHT11
}

void loop() {
delay (1500);
if (digitalRead(D3) == HIGH){
bool PUB = Particle.publish("Vbat1-test", String(dht.getTempCelcius(), 2) + ";" + String(fuel.getVCell(), 2) + ";" + String(fuel.getSoC(),0));
if (PUB == 1){
    digitalWrite(D0, LOW); // wyłączam zasialanie na DHT 11
    System.sleep(SLEEP_MODE_DEEP,600);
}
}
}

In short: the Particle Electron works with 3rd party SIM card, but doesn’t with the original one.

Any ideas?

I submitted a “support ticket” ID 52976 - but since I mostly use this forum to solve my problems (by reading) - I decided to document the case also here, wait for some ideas form the community, and if the thing ever get’s solved, post the solution for others to read in future.


#2

Ok, my bad - I didn’t look up this forum well enough - SPOILER ALERT: this is indeed a SIM failure
.
This issue was investigated in depth in another long thread: [SOLVED] Electron high frequency flashing in cyan

Bravo to @reza @jimmies @jobsight @JeffInCO and as always @ScruffR for the leg work they did to investigate this issue.

I read it all, and have all the similar symptoms.
I already filled a support ticket which is of a number 52976 but now I know the cause (faulty SIM, as I suspected), and the solution - replacement program.

What do you think I should do? Wait for somebody on Particle side respond and than show them the similarities to that documented and resolved problem, or file a new ticket? I don’t want to SPAM Particle Support and make two different threads for one seemingly resolved issue.


#3

As far as I’m aware, they usually respond rather quickly. If you can then show them what’s wrong, and how it could be solved, I’m pretty sure they’re more than willing to help out.


#4

If I’m waiting for ANY response (not counting the auto response I got minutes after posting the original ticket), for 5 days now, should I do smth or is this normal and due to support being overthrown with tickets?

I don’t want to spam or annoy anybody, but on the other hand, I have a test device to deploy into the field, and wouldn’t like to wait for that new SIM for ages.


#5

You may need to consider weekends and US holidays too.


#6

In situations like this, a cloud debug log can be very helpful.

Flash the cloud debug code to your Electron over USB, then monitor the USB serial port to capture a debugging log.

In this case, the following showed up in the log:

connecting to cloud
0000034697 [system] INFO: Cloud: connecting
0000034697 [system] INFO: Cloud: conn    34.699 AT send      56 "AT+UDNSRN=0,\"<deviceid>.udp.particle.io\"\r\n"
    64.711 AT send      56 "AT+UDNSRN=0,\"<deviceid>.udp.particle.io\"\r\n"
    86.732 AT read ERR   9 "\r\nERROR\r\n"
    86.733 AT send      56 "AT+UDNSRN=0,\"<deviceid>.udp.particle.io\"\r\n"
    86.734 AT read  +   14 "\r\n+CIEV: 2,3\r\n"
    86.744 AT read  +   14 "\r\n+CIEV: 2,2\r\n"
    86.754 AT read  +   14 "\r\n+CIEV: 2,3\r\n"
    86.764 AT read  +   14 "\r\n+CIEV: 2,2\r\n"
0000116745 [system] ERROR: Cloud: unable to resolve IP for <deviceid>.udp.particle.io

This particular error occurs when the Particle SIM card is incorrectly configured in the mobile carrier network, such that it cannot do most TCP/IP functions including DNS. This is rare, but happens occasionally and we usually send out a replacement SIM when that happens.


#7

Just to clarify @rickkas7 contacted me on behalf of Particle Support, and helped me to go through the process.
My situation was as I suspected - “factory” configuration problem with my Particle SIM card.
But that was finnaly revealed by the Cloud Debug Log.

If anybody stumbles upon the same situation in future. Make sure to produce the log using “cloud debug log” from post above and attach it to your “support ticket” with reference to this post. This should make the process faster - since than the problem is clear.

I’m waiting for the replacement.

Case closed for me- hopefully:)

Thank you to everybody who tried to help me.