Trouble getting a new electron up: LED flashing cyan

Hi,

I have unpacked my first electron today. I started with the instructions at setup.particle.io. I am not able to get past the SIM activation stage. The device connects to the tower (flashing green changes to flashing cyan) but doesn’t connect to the cloud. The LED keeps flashing cyan for a few minutes before resetting. I am assuming that the device resets as it goes back to breathing white -> flashing green -> flashing cyan, and the cycle continues…

Any kind of help would be appreciated.

I have a hunch that my SIM is not actually activated. Does anyone have an idea whether the actual SIM activation takes longer? I am based in India. Any other reasons that anyone might think is responsible for this?

Thanks.

Just to make sure, your battery is “fully” charged and connected?

Yes. The battery is fully charged. The red charging indicator LED turns off within a couple of minutes of connecting the USB cable.

[EDIT] I am occasionally (1 out of 20 times) getting this sequence: Flashing green-> Flashing cyan-> Couple of orange blinks -> Flashing cyan. I will now try to find and flash the same code that an out of the box electron comes with, Not that I have flashed it till now, but I am clueless and think that there might be some problem with the program currently on the device. Kindly provide any other suggestions meanwhile.

[EDIT2] I reinstalled tinker on my electron with

particle update
particle flash --usb tinker

Still the same old story.

[EDIT 3] Tried the following with no change in result:

particle keys server

I am guessing that the people at [SOLVED] Electron high frequency flashing in cyan are facing the same issue. Maybe the problem is actually SIM related. C’mon particle. Do something.

[EDIT 4] As suggested in above link, I used keys doctor and all the steps completed successfully. I also tried everything with another electron that I have. No change in results. This is such frustrating. :doge:

Have you seen the update in that thread about SIM replacement?

Yes I did. I think I have done enough experiments to ask for a replacement SIM too. Thanks for the help.

I’m having this exact issue, I’ve completed all the steps. Did a replacement sim fix it?

We had to get it running immediately. So we used a spare SIM that we had (not provided by particle). That worked.