Odd Electron flash patterns

I am trying to use an electron but so far I have only had a couple of minutes online, the rest of the day has been spent with odd flash patterns I can’t identify.

Firstly the instructions details a hard reset option, holding down the mode button and letting it go from yellow to white, I can’t get this to happen, anyone else?

I also can’t get it into safe (magenta) mode, if I release the the mode button while flashing magenta it goes straight to white. Is this normal?

The device spends most of its time with a very rapid cyan flash which I can’t identify, it will then occasionally switch to rapid red before switching back to rapid cyan.

Basically lots of coloured lights and no idea whats happening!

Can anyone offer any advice?

Have you got a link to that I can check out?

Could that be orange as well, or definitely red?

It looks like I was looking at the wrong document, the electron doesn’t seem to have a hard reset.

Its definitely switching to red on occasion but it’s sadly too quick to see how many flashes I get.
I have seen orange on occasion.

As soon as I started this thread started working for a few minutes but it’s now back to its fast and very fast cyan flashing, along with the odd bit of red and green for good measure.

That souns like a keys issue.

Try putting the Electron in DFU mode, then run
particle keys server

If that doesn’t fix it you should also try (in DFU mode)
particle keys doctor

1 Like

That’e the problem I was having, but found if I firmly squeezed the SIM between thumb and forefinger it managed to connect and get to breathing cyan.

Unfortunately neither of these helped.

Does anyone know what the fast and very fast cyan flashing means?

When you tried squeezing the SIM, did you do it from power off. I.e. Disconnect sub and battery, squeeze sim against the circuit board, while squeezing it connect power, keep holding it tight until you get cyan breathing.

It is a weird error condition, I have been working with Brett in support to give them error logs and a copy of my firmware.


Just tried that again and still the same :frowning:

I just wish this page listed all the modes so I knew what it was doing.

There is a fast cyan blink which indicates cloud handshake, but I don’t know if this would qualify as “very fast” and usually (when happening over extended periodes) comes with the occassional orange/red burst, indicating the said keys issue.

For more keys issue remedies you could search for “red burst” or “orange burst” - even when intended for the Photon they might work for the Electron too.

Photon setup flashing cyan with a "quick red burst" (now orange burst) [Solved]

It has randomly started working so I don’t think its an issue with keys.
Not sure how long it will last but its getting frustrating!

And its gone again, I guess 12 minutes is better than nothing

I have been frustratingly experiencing the same problem (it seems) - see: Electron G350 connectivity (flash sequence)

Just curious - what Country and What Electron (2G/3G?)

UK and the 2G device.

My flash sequence is a little different to yours, my red portion is only a fraction of a second and I get a bit of green in their to.
Otherwise I think its simmiler.

I think it’s an issue connecting to the particle cloud I just have no idea how to debug it.

my red/orange lasts between 0.5 and 3 seconds - it varies.

Often times i just see green flashing forever, sometimes so long it reverts to blue.

I have had it breathing only a few times. I thought I logged a support ticket (email) but nobody got back to me :frowning:

I have just raised a ticket as it seems from your thread this is a bigger UK issue.

I wish there was some kind of debug output so I knew what it was trying to do.

And I have just seen a big period of flashing red so its probably the same problem as you.

Ah - so are you UK? What electron - 2G, 3G?

I have also tried to open another ticket - see if i have more luck with replay this time.

Yes, UK with the 2G device

OK - same boat as me (and others).

I must say - I have more luck getting to flashing Cyan when I hold a little pressure on the SIM, so there is obviously a physical issue there somewhere, unless my body being near just helps reception of antenna.
Still - I also have a gut feel there is a carrier issue in there somewhere…

Yeah, a carrier issue seems likely or perhaps the additional latency from the UK to the US wasn’t catered for with timeouts or the switch to UDP.

Kind of worrying as they may not be easy to fix.