Electron cycling: flashing green: flashing blue: breathes cyan: flashing green

My electron was unplugged from power for about a week and when I plugged it back in to power it will not reconnect. Before this it worked without problem for several months. The led flashes green for several minutes, then flashes blue for a shorter time then breathes cyan for one or two breaths then starts over again. My programmer is in Poland and I am in California. He cannot access it if it will not connect. Can someone walk me though connecting to the particle cloud through my computer/usb port so he can troubleshoot it? I mean step by step please if possible. Thank you in advance.

The first thing to try in such case would be Safe Mode.

Also the blue flashes in between sound odd. Can you post a video of this?

Thank you for your reply ScruffR.

I attempted to put it in Safe mode without success by holding down both buttons then releasing the reset button and holding the mode button until it blinks magenta. After performing this it immediately goes back to the same behavior of green, blue,cyan, green blue cyan.

The app will not let me upload a .mov.

Any other ideas? Is there a factory reset?

Placed in DFU mode and used command particle update. Same behavior.
Placed in DFU mode and used command particle flash --usb tinker

Still will not go into safe mode

Same behavior. Fast blinking green, fast blinking blue, two cyan breaths then repeat.

I put the sim from my cell phone in and it blinks green for a minute then goes to cyan breathing x2 then back to green blinking. Does not blink blue like with the particle sim card. Not sure what this means.

Did you check to make sure that the electron works for both Poland and California?

@kennethlimcp, as I understand the device sits in California - only the developer sits in Poland and hence has no physical access to the device. But the question is valid. @Spencer what is written on the ublox module of the Electron (G350, U260 or U270)?

@Spencer, you can upload your video to YouTube (or any other platform) and post a link.

https://youtu.be/2-Dk6WkBETM

Thanks for your help ScruffR.

The device is a U260. It resides in California. The programmer works from Poland. It has worked fine including many programing revisions that he performed remotely. It was working as expected up to a week ago. I unplugged the main power source. The small lipo battery remained plugged in.
This morning I plugged in the main battery and it wouldn’t connect and the light sequence is as described.
I have also removed and cleaned the SIM card with no effect.
I have pressed firmly on the SIM and pushed the reset button with no effect.
I have removed the antenna and reseated it. No change in the blinking pattern.
I have pressed both the reset and mode button then released the reset button and when the LED blinks magenta I released the mode button to put it into safe mode. This procedure has no effect either.

Hmm, I could not see any dark blue RGB in that video :confused:
I only saw cyan blinking, white breathing and green blinking - and it was a bit short.

Could you post a video of starting Safe Mode and at least 30sec - an Electron cold connect is allowed to take up to five minutes.

Here is a longer video. It starts with me plugging in the small lipo battery. The LED starts off cyan, then blinks green for a minute or so, blinks blue for a few seconds then breathes cyan twice and goes back to blinking green. I do not see any white. It may be a trick of the camera or compression or your monitor (or my eyes.)
Thanks.
https://youtu.be/qlotKSV-KOo

Might also want to check on the billing just to be sure that the data limit has not been hit?

Thank you Kenneththlimcp, I checked. There is ton’s of unused data.

Also I have left the device on and trying to connect all afternoon but it just keeps cycling these lights.
I have taken the device about 5 miles away and had cell phone service on my phone the whole time but it still does not connect.

The Electron will NOT have enough power to connect if you don’t have the 2000 mA/h battery that came with it. Connecting USB only will not work either. During the connection process, the U260 can draw a lot of current (1A+). Make sure you a) Have a good quality USB supply and b) have a fully charged 2000mA/h battery connected. Also, I am assuming the antenna is correctly connected.

1 Like

That breathing after cyan blink looks white (all RGB sub LEDs on) to me. And that might well be the code doing that, hence I’d have liked to see you try to enter Safe Mode.

And of course as @peekay123 said, check the charge of the battery, the fitting of the antenna and SIM, maybe even plug in USB to provide extra power.

i’m wondering if after you unplugged the main power source and it was on small lipo only if that lipo was allowed to drain. if so, there have been several issues with electrons that have been allowed to drain the lipo battery and then power off. you may want to search for those threads.

Thank you peekay123.
The video starts with me plugging in the battery that came with it. I am assuming that is fully charged as when the USB and the main power cables are connected the red light does not come on. After letting it do it’s thing all night I connected the USB and the main power (22.2v 8a lipo) the red light indicating the battery is charging came on this morning. From that I figure when the video was made that the small battery that came with it was fully charged. Also this morning with the main battery, the small battery that comes with it and the USB from my computer connected, there is no change in the behavior. When I perform the safe mode procedure there is not change in the behavior.

Thank you dkryder. Yes that is exactly what happened I believe. The lipo that came with it slowly discharged. I will look at those threads. Thanks for your input.

dkryder,
I see that people are having difficulty after fully discharging the battery. The devices seem to be bricked but frankly, the conversation is beyond the scope of my practice. I can get it into DFU mode and I reflashed tinker according to the instructions. The behavior does not change. Is there a way to contact Particle for a warranty request or do I just order another one. The support page is a circle leading back to the support page.

I figured out how to email particle. Thank you.

Spencer,
I would imagine that the other gentlemen helping you in this thread are better suited to help you with questions on warranty, or , better yet , help you get yours working again. they all are better connected to the company. i just read the forum as part of my education and reply when i have read something i think may be of use.