Electron suddenly can’t connect (blinking cyan + 3 orange)

I have a a Particle Electron that has been running nearly 24/7 for several months suddenly unable to connect as of April 14th. When I check the status LED, I see the following sequence…

  1. White: breathing (a couple seconds)
  2. Green flashing (around 15 seconds)
  3. Cyan (less than a second)
  4. 3 Orange flashes
  5. Cyan flashing
  6. Repeat

The tutorial for this devices says the meaning of 3 orange blinks is: “Connected to the internet, but could not reach the Particle Device Cloud. This sometimes is seen as yellow or red and indicates bad server keys.”

Also, for some background: I am using the official SIM card. This system was using firmware version 0.5.4, and I have a second. identical system using version 0.7.0 that is able to connect.

I’m about to follow the repair instructions per: https://docs.particle.io/tutorials/device-os/led/electron/#red-blink-basic-errors. This requires removing my Electron module from the assembly to establish the command line interface (CLI). However based on a similar topic from February, I don’t expect it to work.

I really will need to know if this bad server key problem is avoidable or what a likely root cause is. The system worked just fine for many months and suddenly stopped connecting without warning.

Assuming it’s the Electron is in the same account as your community forum email, it’s still able to connect to cellular, last connection was today, consistent with getting a cyan blink.

It’s most likely a keys problem, but it’s a cloud public key mis-match, not a private device key. That would be corrected by:

particle keys server

in DFU mode (blinking yellow). The cloud-side logs are different based on which key is wrong, and also the fact that it fails so quickly make it most likely a public key issue. However, it’s possible that both keys are bad and one problem is hiding behind another, so you should just fix both keys while you’re at it.

particle keys server
particle keys doctor

While you’re at it, you might as well upgrade the system firmware. 0.7.0 and later can automatically fix the cloud public key if it becomes corrupted.

I installed the command line interface (CLI) tool for Windows 10, and entered “particle keys server” after the installation (including drivers) was complete.

After putting the Particle in DFU mode and re-entering “particle keys server,” the status LED now blinks:

  1. Green (less than 1 second)
  2. Cyan (moderate blink rate)
  3. Cyan (very fast blink rate for several minutes)
  4. Red (blinking just as fast as cyan. Maybe about 5-10 blinks for 1 second)

When I enter “particle keys doctor” I get an error message saying: "Parameter ‘device’ is required. I added the numeric ID and re-entered "particle keys doctor [device ID number].

At this point, the CLI says I need to be in DFU mode again. When I hold down the Mode and Reset keys to enter DFU mode like before, DFU mode does not start, even after holding the buttons down for several minutes.

Running out of ideas, I tried hitting the reset button repeatedly, unplugging the Electron, holding down the buttons with random timing, pressing the buttons in random order, resetting and unplugging again for about 10 minutes. Finally, (don’t ask me how) I got into DFU mode again by holding down the buttons. I re-entered "particle keys doctor [device ID number] and got the message: "New Key Created! Make sure your device is in DFU mode (blinking yellow), and that your computer is online. I couldn’t find the fille: [device ID ]_ec_new.der. I really have no idea what a .der file is, or what its significance is at this point.

At this point the device was not yet visible on the Console. After resetting, the system still gets stuck at flashing cyan. This is the fast flash rate: as if the module is on the verge of connecting. But it is still 100% un-reachable.

Because you need to release the RESET button but keep on holding SEUPT - otherwise you just keep the device in reset state.

This happened to me with a few (really) old Cores that had been running fine for years. The fix for me was:

  1. Connect the device to a computer via USB and put the device in DFU mode
  2. Run: particle keys doctor <device id>
  3. If the device does not stay in DFU mode after step 2, put it back in DFU mode
  4. Run: particle flash --usb tinker

That got my Cores back online. You will need to re-flash your original code to the Electron afterwards. If possible, I would recommend recompiling (either cloud or locally) with the latest firmware version.

The module is still unreachable. I went ahead and removed it from the circuit assembly it was seated in, and replaced it with a spare Electron I hadn’t used yet. I’ve activated and claimed this new module, and updated it immediately from version 0.5.4 to version 0.7.0.

I took the unreachable Electron and put it in DFU mode again…

  1. I ran: particle keys doctor <device id>
  2. Response was:
    New Key Created!
    Make sure your device is in DFU mode (blinking yellow), and that your computer is online.: I couldn't find the file <device id>_ec_new.der
  3. I ran: particle flash --usb tinker
  4. Response was: flash success!

As of now, the module is doing the same thing as before:

  1. Flashing green
  2. Flashing cyan rapidly (>1 minute)
  3. Flashing red (1-2 seconds)
  4. Repeat

I’d just consider it a destroyed device, since I’ve already tested the replacement and am pretty much at the point of diminishing returns for diagnosing this. Unless fixing whatever a .der file manages is a short process (<1 hour).

Obviously that didn’t work.
Can you find the *_ec_new.der file anywhere on your machine?
Did you - by any chance - run that command from a directory without write permission?

With particle keys doctor you should usually also run particle keys server to be on the safe side.