Electron rapidly flashes green then cyan forever

Not sure what the issue is. I’m totally new to hardware, and have tried everything I could find in the docs & forum. When I claimed it originally, it worked fine. After flashing one of the example apps this morning and failing to get it to work, I gave up and reflashed tinker OTA (successfully I think). It restarted and went into this mode. I’ve updated the firmware with particle update but no change in behavior.

@dcabrera, is there still data available for your account?

There should be. The only thing I’ve done with it OTA is flashed Tinker once. The dashboard says “No data used yet” though.

Cool. Can you place the electron in Safe mode and see if it breathes cyan successfully?

Since it past the breathing green state, the cellular connection should be fine.

Having trouble getting it in safe mode: After releasing RESET, it flashes magenta a couple times. Then when I release MODE, it goes back to white-ish, then green, then cyan flashing again.

Though in a new plot twist, after 30 seconds or so it started breathing dark blue for maybe 10 seconds, then back to flashing green, then the perpetual cyan.

BTW thanks a ton for your help troubleshooting this.

Hmm… Are you using the latest CLI? Try doing particle update and particle flash --usb tinker… if it still doesn’t work, we can load a debug tinker app to see what’s going on.

Yep, ran those exact commands this morning before creating this post.

have you tried it with the electron not plugged into anything - my G350 is not reliable if it’s plugged into any other board or breadboard, as soon as it’s in free space it works much better! Kind of frustrating as I can’t use it to control anything.

@dcabrera can you try the steps here: https://particle.faqt.co/share/h867h4

Sent a PM last night with the log. Thanks for your help @kennethlimcp.

Also, @wdj thanks for the tip. I hadn’t thought to try it outside of the breadboard. I’ll give that a shot this morning.

@wdj no luck on that trick. I had the same experience when using the Electron unplugged from the board. Thanks for replying though!

Did you ever get this resolved ? I am encountering same issue, ran through all steps, nothing…


Strangely enough having the same issue with a few P1 modules. It all started after flashing Tinker, and no amount of updating firmware or reseting keys helped.

@kmtm are they all blinking green?

@kennethlimcp, there is a double post about this here
After flashing firmware, unrecoverable hard fault, cannot boot into safe mode

1 Like