Electron not connecting to the Cellular network and Particle Cloud

Hello, I have many particle electron and I used them regularly without any problem. I powered one of them with an active sim card, first it connected to che cloud but after 5 minutes it never connected again. Now, whatever I do, it is not connecting to the Particle Cloud.

The starting led sequence is different from other electron, because this one is only breathing white and not blinking green or breathing cyan: the electron breaths white, after 5 minutes it breaths blue, then after 30 seconds it blinks blue (but this is not as the listening mode, because every call from the particle cli is not working, I suspect due to threads queues).

I am sure that the sim is working because on other electron it works.

I tried updating the particle cli and updating the Electron system firmware with particle update. I tried particle device doctor, particle keys server etc…

I flashed tinker from the cli or created simple firmwares that just set the system mode to manual and call Cellular.connect() or Cellular.listen() etc. None of these solutions worked.

It seems like something is wrong with the cellular because in system mode manual I can execute any program I write, except for the cellular connection, that blocks the electron when trying to call Cellular.connect(); or Particle.connect()

Do anyone experienced something similar? Any solution?

Have you seen my comment about Cellular.on() when using SYSTEM_MODE(MANUAL) in the other thread?