Core not getting on network that worked yesterday [SOLVED]

Hi,

I was able to get the core onboarded to my iphone hot spot yesterday with help of the mobile app running on an ipad logged into the same hotspot. Today I tried to register it to my wlan at home - that failed (also fails for the photon i have) so i thought “no problem - it worked ok with the iphone hotspot - lets go back to that”. So i deleted the memory (press mode button for 10 seconds) and reset the firmware (hold mode, reset, then hold mode until it blinks white).

Unfortunatly what worked yesterday does not work anymore today. I have not changed anything on the phone. I also tried the serial monitor procedure with i (provides the core id) and w … to enter SSID and security and password with the same results. I cannot claim it back.

I of course went through all the troubleshooting guides but except the CLI i tried all of the tips and tricks.

Can someone help with what might be wrong? I have the feeling the core is a little left behind (troubleshooting page of the core links to an USB procedure but the link is going nowhere).

Regards, Marcus from Heidelberg

PS: I have the feeling the Electric Imp I have been using at my work is much less finicky about networks and the onboarding is more reliable.

I recently upgraded to the new Photon and its rock sold compared to the old Cores. Granted I have not used the Cores in a long time all I can say is that Photon is everything I wanted the Core to be.

I would upgrade to the Photon and not have to deal with the headaches. Just my 2 cents.

Although the Photon is quite a bit better, the Cores should still work.
When configuring the device, does it connect to the cloud (breathing cyan)? If not, then what color pattern is the LED presenting?

Im wondering if this has happened to you? how do you power your core?

Yes, the photon i have worked better. Until I flashed a program that would put the photon to deep sleep right away - this prevented any further firmware update and also prevented a factory firmware reset - I woul donly get to the yellow blinking lights but not to the white blinking lights anymore.

But I was able to recover both the photon and the core by using the instructions here: https://docs.particle.io/support/troubleshooting/connection-help/core/

I provided a suggestion to change this article to mention the need to use the zadig tool on windows to make this work. Especially newbee hackers like me do not necessarly have the whole tool chain setup (CLI, path, dfa_util, zadig). Furthermore it would be good to provide instructions for the photon to do a full firmware upgrade - i guess the photon does not use a cc3000 but a broadcom chip, right?

Some thoughts; the photon does not have a factory reset, which is probably why you couldn’t get it working. The deep sleep doesn’t prevent this, because using those button combinations overrides that.
Using safe mode would be ideal in this case, since it does allow a connection, but won’t run your ‘sleepy’ user firmware, thus allowing you to OTA new firmware.

Either flash an application through the online IDE, or issue particle update from the CLI while in DFU mode.
And it indeed doesn’t use a CC3000 but rather a Broadcom chip (the exact one is mentioned in the docs if I’m not mistaken)

Thanks a lot - where ist this safe mode described and how do get a photon into it?

I struggle a little with a lot of documentation on core and photon not beeing clear to which of the 2 it applies. For example the page illustrating states for both does not show that factory reset is not available on photon. And I work with a lot of different microcontrollers - so I don not get to read all of the forum entries to find out what really works.

Sorry for nagging - I forked the documentation on git to fix this - hope my pull request will be accepted.

Try the search feature of the docs.
The results usually come with an indication to what device the info refers.

1 Like