"No cores found [SOLVED]"


I just received my Spark Core. Unfortunately I cannot find it with the iPhone application. It just says “No Cores found.” after searching for a core for a long time. The core blinks blue all the time.

I am using AirPort and iPhone and the network does have a password.

Any ideas what could be wrong or how to continue from here?


Hello @Sauli
Just to get you started, first sanity check: Could you confirm the type of the Core you got? If its a u.FL Core, do you have an antenna connected to it?

If the the iPhone app is unsuccessful at connecting to the Core after following instructions on these pages:

You can try connecting the Core via the USB:

Hope this helps!

The core is the one with the chip antenna. No need for an external antenna.

The WiFi trouble shooting section did not help. Luckily I was not able to connect the Core with the USB cable. The Core and programming it with the web browser and/or Tinker works now ok.

I, however, would like to solve the problem with getting the network configured with iPhone and Time Capsule that both have the basic settings and nothing extra as far as I know. Do you have any ideas what to try after going through the trouble shooting section on the website?

You might want to check which band your iPhone is using. I had problems picking up the Core because my iPhone was connected to my router on the 5GHz band, while the core will only connect to a 2.4GHz band. when I turned off the 5GHz band it worked for me.

Might be worth looking at that.


Be sure to power-cycle your Core after a few failed tries… after failing multiple times, I power-cycled mine (yes, it was blinking blue the whole time), it magically worked the first time. Could be a memory leak?

Hello @Sauli,
What @elbeardo mentions is true. Can you verify this at your end? Currently the TI’s smart config has been observed to have issues.

I could not get my Spark Cores to work with my iPhone 5S but they work fine with my 4 and 4S.

Connecting to 2.4GHz network instead of 5GHz did help me to solve the problem.

I had to set the Time Capsule (not Airport as I said beofre) to provide both the 5GHz network and then the 2.4GHz. Then I chose the 2.4GHz network with my iPhone 5 and everything went just fine from there.

The way how the Time Capsule is set to provide the separate 2.4GHz network was a bit confusing. It was done by asking the Time Capsule to name the 5 GHz network with the 5 GHz suffix. That resulted as a 2.4 GHz network to become available.

Thanks for helping out with this issue.

1 Like