No Cores Found - Can't connect to spark core

I recently bought a Spark Core, but I have not been able to connect to it in any way. It is a chip antenna core. The power source for the core is definitely strong enough, and my router is pretty powerful. I am using a 2.4GHz b/g/n network on channel 8 with WPA2-PSK [AES] encryption. I have tried using the android app multiple times. The core continues to blink blue and, after a while, the app says “no cores found.”

I have tried connecting with my computer, but that raises another problem. At the step where I type “npm install -g particle-cli” in the command line, I get multiple errors. I have tried using both the regular command line and the node.js command line installed earlier in the tutorial. Both failed at “node-pre-gyp install --fallback-to-build” and mentioned problems with the serial package.

I don’t necessarily need to use one specific method, so if I could get at least one of them working that would be great. Thanks!

Place the core in Listening mode, use a serial terminal program and hit w then send in wifi credentials accordingly.

Great, that seemed to work. Now how do I connect my mobile app to it?

The mobile app might not work 100% depending on the network environment you have. You can attempt to place the Spark core in Listening mode and see if it works.

That didn’t work. Is there any other way for me to connect to it over the internet? Or even with a usb cord?

Did the method i mentioned above not work?

I can’t connect to it using the mobile app. If you mean the terminal, I was able to send the credentials but I don’t know how to do anything else.

So what should I do? I got a spark so I could put it in a hard-to-reach place and not have to worry about updating it with cables… I don’t care if I have to use the web IDE or the mobile app.


  • Did you managed to get the Core connected and listed in your account?

The led is indicating a good network connection, but I can’t connect to it

What do you mean when you say the led is indicating a good network connection? What is the exact colour?

@kennethlimcp Where is the documentation for communicating with the core in listening mode? I stumbled upon this post the other day when my core was locked up and it was really helpful. Thanks :+1: I’m curious what other commands are available in this mode.

I don’t remember it being documented anywhere but for now you can refer here:

Opened an issue here to get it introduced in docs:


Sorry about the quality, I had to resize it so it would upload

It is “breathing” this color

Is there anything else I can try? Or am I stuck like this?

If it is breathing cyan means it’s connected to the :cloud:.

Are you able to flash new user firmware?