Spark will not connect neither through app or USB


I ordered m spark core from Kickstarter a while back, but only tried to use it now, I just powered up with spark core and downloaded the app. I was connected through Wifi and fired up the app. I put in the wireless password and the core started blinking green, but never advanced to any later stage of connection. I tried resetting it and holding the mode button for 3 and 10 seconds and trying again and again, and nothing.

Then I follow the tutorial on how to claim your core, I installed the driver and open the spark command line interface. It asked for my login details, I put that in and everything was ok. Then I typed spark setup, it asked for SSID and password and said please wait until your core is breathing cyan and then press ENTER.

The core restarts and starts blinking Green but never goes past that stage. My wireless router is NetCommWireless NB604N. Are there an settings I need to change in my router, or is the issue in the SparkCore itself?

What else can I do?



Have you tried all these steps:, Including the CC3000 patch/deep upgrade? Might help.

1 Like


Thank you for your suggestion.I believe I have been able to install the CC3000 patch after 2 hours, but it still doesn’t work :confused:

I also saw people changing wifi settings to WPA and WPA2, I tried both, I tried changing password, it is not helping. Tried again claiming my core, still nothing.

An other ideas?


how did you perform a CC3000 patch? Via DFU-Util or Spark-cli?


After more updates (deep upgrade) I was able to connect the core through the wifi setup in the console.
Now I am able to upload sketches through the cloud, but I still can’t connect through my phone. ANy ideas?

Hi xlev,

If you want to use the mobile app to control the core, you will need to run the tinker firmware on it.

Look under the settings tab in your phone, you should find a reflash tinker button. :wink:

Once that is flashed, you will be able to control it via the mobile app!

1 Like

Thank you so much!!!

Can’t believe its working! This is awesome!!! Thank you @Moors7 and thank you @kennethlimcp !

1 Like