Unable to Connect Spark Core using Spark App

Sorry if this has already been answered.
Does anyone know how Spark Core WIFI module is connecting to the Spark App on your mobile device?

I’m trying to figure out what the problem is with my wireless devices, and why they cannot seem to connect to the Spark Core using the App. I have been able to establish the WIFI connection by using the USB CLI prompt, but I want to be able to be able to make connection using any WIFI device without having to rely on the CLI.

So far I have used both my Samsung Android tablet and the IPhone 6. Neither seem to work.
Although, yesterday when I brought the Spark Core device over to my friend tried it out at his house, he was able to establish connection using the Spark Core app on his phone, but again it wouldn’t work on my phone.

Again I have tried several attempts resetting the Spark Core Device and turning on the listen mode, but to no avail. Anyone have any ideas on what I can do?

Might want to check if you are on the 2.4Ghz ssid :slight_smile:

Yep, I am on a 2.4 Ghz SSID.
The funny thing is I was on the same network as my friend who has the same type of iPhone as I did and he got connected via Wireless Spark Core App and I wasn’t. I just don’t know where the difference lies.
It’s possible he has a different version of Spark Core than I do, but I don’t see where you can figure out what version of the Spark Core App he is using and what I am using.

Interesting… Can you test with the latest Particle app instead?

@kennethlimcp, I don’t believe the latest Particle app supports the CC3000 and thus the reason for the Spark Core app. @Xanatos, if your friend’s phone can connect, then you may want to focus on what is different in your phone’s WiFi setup. Do you have tethering enabled or anything else which could affect the connection?

There shouldn’t be anything like tethering enabled on my phone. the only difference might be the Bluetooth devices enabled, but I can’t see how this would interfere with the Spark Core App.
Not sure if there is any other differences other than the possibility of the version difference for the Spark Core App.

@Xanatos, if version concern you then uninstall what you have and re-install. Disable your bluetooth during the test, just in case. Many users have found the TI CC3000 mechanism to be unreliable. This is why you can setup you wifi credentials via a serial USB interface with or without Particle CLI.

Yeah, I have actually uninstalled mine a number of times and I have disabled the bluetooth, and still no luck. I am guessing that TI CC3000 protocol for establishing a WIFI via wireless device is hokey. I will note that for future projects.
It would be helpful if I understood how the Spark Core application goes about trying to assign the WIFI router via wireless device, but haven’t been able to find this documentation anywhere.