AVOID factory reset - What to do with unexpected LED behavior on a Photon

Hello, I probably need some help with my Photon, which now has slow breathing white along with a tiny red at its corner after I made a factory reset to it. I cannot make it to listening mode by pressing ‘SETUP’ for three seconds, nor connect it through ‘cmd’ afterwards. How can I make it back to work? Thanks a lot!

Can you get it into DFU mode? https://docs.particle.io/guide/getting-started/modes/photon/#dfu-mode-device-firmware-upgrade-

Yes. I have blinking yellow now.

Please install the latest release from https://github.com/spark/firmware/releases/tag/v0.4.4-rc.3 and let me know if that helps.

It works, thanks! I’m able to turn on the listening mode now. There’s one more question though. For some reason, I couldn’t claim the core, which is currently owned by someone else. I tried the app on my phone, over the usb and the page on Particle Build.

Glad to hear it’s working. Please create a ticket about not being able to claim with our support team. Thanks!

This thread mentions putting the core in “safe mode” and points to this page as a reference:

http://docs.particle.io/photon/modes/#selecting-various-modes-safe-mode

However I cannot find any reference to “safe mode” on that page.

Jim

Double check you have “Photon” selected in the top right, then you’ll find it under “Standard Modes”.

1 Like

Thank you so much. I didn’t even see that selector in the upper right. It was missing because I had Core selected.
Thanks again.
Jim

So I’ve got one of my photon’s in a state that took a while to recover from… and yes I factory reset but after upgrading to 0.4.3 firmware


I had flashed it to 0.4.3 and everything was working great…
Then a stupid peace of code put it into such a tight loop that I could not get it to flash… while (1);
So, not knowing of safe mode, I factory reset it.

Now when I power it up it immediately flashes fast yellow
The reset button does nothing on it’s own, but when you press it both it flash cyan a couple times and always goes back to blinking yellow no matter how fast I release.

“particle list” doesn’t show the device
dfu-util -l does show the device

Found DFU: [2b04:d006] ver=0200, devnum=60, cfg=1, intf=0, alt=1, name="@DCT Flash /0x00000000/01016Kg", serial=“00000000010C”*
Found DFU: [2b04:d006] ver=0200, devnum=60, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/03016Ka,01016Kg,01064Kg,07128Kg", serial=“00000000010C”**

after flashing with 0.4.4 using DFU-UTIL got back to the blinking blue,
reclaimed it

and things seem fine now

Hopefully this might help others

2 Likes

I hope you were able to get yours fixed. I received my new Internet Button (photon) about a week ago and was getting a solid green. I did the factory reset and then was getting a solid white. I got it into DFU-mode and I got the exact error you did, and I couldn’t seem to get past it. I then left it on the shelf for a week.

This morning, I powered it up, put it in DFU-mode and updated the firmware, got the same error, but then was able to flash it with the particle CLI… It is working fine now!

I would suggest DFU-mode, then update firmware, then try
particle list

If it sees your device, regardless of online/offline status, copy the name and do
particle flash your-device-name tinker

You can also try safe mode and firmware reset… This picture was super useful to me in explaining how to get to the different modes.
https://docs.particle.io/assets/images/photon-reset-modes.png

hey @ladysarakat @tachijuan we’re making some changes to this system of modes since Factory Reset and Firmware Reset has had some issues (more info in the next firmware release). I’m generally recommending Safe Mode over everything else for now, it’s also easiest to get to since it’s the first one that comes up when you hold SETUP and tap RESET.

Hi Ashton, I am having the same mistake…a never ending loop with these flashes. ¿could you tell me how did you fix it?. I’ve being trying for 5 days now…Thanx

I can’t get this to work, I have downloaded version 0.4.9 of teh firmware but when I try to compile it from CLI I get:
particle compile photon C:\Users\Per\Documents\Particle\firmware-0.4.9

Compiling code for photon

Including:
attempting to compile firmware
Compile failed. Exiting.
build.mk:37: *** "No sources found in ". Stop.
make: *** [user] Error 2

What am I doing wrong?

If you’ve got a .bin file, it’s already compiled. Simply do particle flash --usb [nameOfFile].bin then. Alternatively, for updating you can do particle update, which should work if you’ve got the latest CLI version.

I don’t see any .bin file in the package I have downloaded.

When I try to run the particle update command I get:

Your environment has been set up for using Node.js 5.6.0 (x64) and npm.

C:\Users\Per>particle update
!!! There was an error trying execute DFU utilities.

!!! For help with installing DFU Utilities, please see:
 https://docs.particle.io/guide/tools-and-features/cli/#advanced-install

!!! You may also find our community forums helpful:
 https://community.particle.io/

Error code: 1

I have looked at the installation guide for Windows, which is really confusing and did not find any clues as to what is going wrong. Any suggestions?

If you haven’t got a .bin file, then it might certainly help if you could tell us what you do have and what it is you’re trying to achieve.
Going back through the post you’ve responded to, it seems as though a system update was required, for which precompiled .bin files have been made available. You can find those here: Releases · particle-iot/device-os · GitHub

How about this?

I believe this is what you’real looking for:

That said, since you’real on Windows anyhow, you might take the easy way as well:

Use that tool, and select which parts of the Toolchain you’d like to install. Since you’ round got Node and the CLI installed already, you should suffice with DFU-UTIL only.

Let me know if that worked :slight_smile:

1 Like

Thank you for response.

I tried to install the full Toolchain package but that failed with an Error 404 while downloading, as I have reported elsewhere. But installing just the DFU-UTIL actually works and now the error about not being able to execute DFU Utilities is gone.

So I tried to put my Particle in DFU mode and run particle update but that results in:

C:\Users\Per>particle update

!!! I was unable to detect any devices in DFU mode...

> Your device will blink yellow when in DFU mode.
> If your device is not blinking yellow, please:

1) Press and hold both the RESET/RST and MODE/SETUP buttons simultaneously.

2) Release only the RESET/RST button while continuing to hold the MODE/SETUP button.

3) Release the MODE/SETUP button once the device begins to blink yellow.

But my Particle is connected to USB with a USB cable that I have used before for the serial communication and the particle is happily blinking yellow. Any idears?