Xenon flashing green rapidly after updating to 1.4.4 and never gets to the cloud


#1

I realize that the title “Xenon flashing green” is found more than once but none of what is mentioned works consistently.

Today, I received from Particle 3 Xenons. They had an older firmware (1.21) so I updated all of them using OTA.to 1.4.4

Two units worked fine after the upgrade. The third never completed the upgrade. I then tried to delete and rejoin the mesh network (with an Argon), everything works. When the power is reset, it returns to fleshing green.

I then used particle update. That did work and I upgraded firmware to 1.4.4 and unit was breathing cyan.

I then recycled power and it is back flashing green for ever! I cannot place the unit in safe mode (starts flashing magenta then returns to flashing green upon mode release).

I know the Gateway is working (because when powering more Xenon units, they all connect).

Do I have a defective unit?

===============================

Update:

I unplugged the Xenon for about 10 minutes. When powered again, it hooked up to the cloud (via the Argon). I then re-flashed the same code and now it seems to be working.

Not sure why though?


#2

Because the first OTA attempt failed, were you left with the ‘marking setup done’ incorrectly??
Have a read of the following re updates via USB

https://docs.particle.io/support/particle-devices-faq/mesh-setup-over-usb/#marking-setup-done

Please bear in mind that I am very much a novice but had some similar issues myself before I tried the above. Something to work on at least.

paul


#3

Thank you @paulWatty. Will try it.