Xenon keep sos'ing 10x when trying to upload update

xenon
Tags: #<Tag:0x00007f1cad935410>

#1

I already succeeded the update of my Xenon at installation time.
Did it without an Argon. And connected it with Workbench time ago.
Now I was trying to place it on a mesh. I got my Argon.
As far as I know the only tool is the Particle app.
I went thru all the procedure again adding my Xenon. Up to Pairing OK. Then I have to update it.
Here it stops and sos 10x.
I reset it. Still the same.

Using IoS app. As I used in the past.

Any suggestion?


#2

https://docs.particle.io/tutorials/device-os/led/xenon/#red-flash-sos

That seems to be an assertion fault which mostly is caused by some object constructor calling a function from an object that’s not yet instantiated.
Showing the code that’s currently running on your device might help poinpointing the cause.


#3

Ah OK!
I will check this when I will be able to connect the Workbench again.
I made another request for help on the forum for this :slight_smile:
Thanks for the answer.


#4

I was able to recover placing my Xenon in safe mode. Then used the app to update and now asking to join a mesh. So far so good… Now will need to enable my Argon… will let you know.
Thanks again


#5

My Xenon is breathing white. And never connect to my Argon and never goes on-line.
My application is still running in the Xenon and probably giving some problem. I can see it running from the serial port.
Since I cannot use Workbench (still under help in the forum) I do not know how to reset it with another software or just flash a simple loop. Any idea on how to flash something without Workbench and without installing anything else if possible?


#6

Again, what does it do in Safe Mode?

Breathing white means the radio module(s) are switched off (e.g. due to use of SYSTEM_MODE() or any of the xxxx.off() commands).

If we only had some means to know what that application does.


#7

The application runs a CO2 sensor, and it does it, I can see my data thru the serial, but then should connect on-line and send the data to Thingspeak. This is done for the Photon but I was just trying to flash something and check if it would run with the idea to change it later.
Now I am stuck with it and cannot connect the Xenon.

In safe mode it let me go thru the app procedure that reads the QR code. Before the safe mode it would not even do this.
Now I can make the Xenon flash blue to get the connection. Pairing is fine. But before connecting with the Argon it turn white and stick there. Argon connect to the cloud and wait for Xenon. But the Xenon rather goes to white breathing.
You are right. It could well be that I turned off the radio to make my testing off-line. How to erase this now?


#8

Found the solution.
Used workbench “cloud compile” (this worked)
Then placed the xenon in dfu-mode
send the command “particle flash --usb .\filename.bin”

Flash success!
Xenon went to green fast flash and connected as soon as I powered ON my Argon.

Great stuff.
Still need to have Workbench working and all will be great…


#9

Actually no. You wouldn’t need Workbench. You can build via Web IDE or CLI and get the resulting binary to flash.

However, having Workbench is worth having for other reasons :wink: