WiFi Problems? Disable 5GHz on your router

I can confirm a but that I’ve found. I use dual band wifi (both 2.4 and 5 GHz). My iPhone will prefer 5 GHz and the spark core can only do 2.4 GHz. If you try and use the app it will never send the wifi credentials over to the spark because the phone will try and communicate with it over 5 GHz. I had to disable 5 GHz for my wifi network to get it to connect.

Thanks for the information! This is a known issue with CC3000 and I believe the docs mentioned to use only a 2.4Ghz Wifi router. :slight_smile:

I have a router which supports both bands. The trick is to run each band with a different SSID. The 2.4G band has a SSID similar like ‘JoesWifi’ and the 5G band has SSID ‘JoesWifi+’

1 Like