Spark Core won't work with default 'home' network, but works with mobile hotspot

My Particle Core (chip antenna) arrived yesterday, but unfortunately I have not able to get it to work with my home WiFi network. Flashing green LED, no matter how many times I try.

I realise this is a common issue, and have looked at many related topics.

  • WiFi credentials are definitely correct
  • Range should not be an issue, Core is close to router
  • Core is powered by laptop
  • Have tried to set it up using Android Spark app as well as via USB (multiple times)
  • Did a factory reset and updated the software on the CC3000 (multiple times)
  • Manually entered SSID and password

The WiFi network I am trying to connect to is 2.4GHz and has WPA2 encryption. If I set up a hotspot with my phone, the Core happily connects within seconds, which is great, but I really need it to connect to the router…

What else can I try?

Glad to hear that! Means the CC3000 patch went ok and is working fine :smile:

Can you provide more information about your home network?

Yes, it is good to know that the Core definitely does work :smile:

The network is via a Virgin Media Super Hub, 2.4GHz & 5GHz dual band wireless, 802.11b/g/n. When I attempt to set up the Core via an Android tablet, the tablet is connected to 2.4GHz. What other information could be useful?

Are you trying to send Wifi credentials via the mobile app?

Also, try turning off 5GHz or setup a separate 2.4GHz SSID if possible. Trying only b/g mode might also be another choice

1 Like

I have set up a separate 2.4GHz SSID.

When I try sending the WiFi credentials via the mobile app it gives the ‘No Cores found’ message after a while. The LED remains blue (blinking).

When I try setting up the WiFi via USB, the LED starts blinking green.


Does switching to 2.4GHz b/g mode work?

@BlinkingGreen, also make sure your phone is on the same 2.4GHz SSID as the Core.

1 Like

Having some issues trying to figure out how to switch to 2.4GHz b/g, but will look into this, thank you.

Tried several other things, including disabling 5GHz completely, changing the SSID (thought it might be an issue with a special character), but no luck yet.

1 Like

Thank you, yes, I have made sure this is the case :wink:

WPA2 should work well though you can try switching to WPA.

It’s probably too much guesswork here but if you have a screenshot of the router setting we can have a look :wink:

I have just disabled security completely so that the network is open, and even then the Core does not connect (green blinking LED). So, probably not a WPA2 issue?

Attached a screenshot of some of the settings. I believe the ‘Wireless mode’ options represent the switch between 802.11b/g/n, but I have had no luck when connecting the Core in 54, 144, or 300. Any idea what the issue could be?

Ok try this:

  • Up to 54Mbps
  • Greenfield mode off
  • Channel set to < 11

Interesting: it still does not work, but with these settings other devices (that work on 2.4GHz) appear to have authentication problems too. Not sure what to do about that, but we seem to be getting closer to the problem, thank you for your help!

Then you probably have to check the home router and make sure other devices can connect ok first :wink: