Having trouble connecting the Spark Core to a particular wifi AP [Solved]

My Spark Core connects fine and without problems to my Modem/Wifi Router (a Cisco). However, I am having trouble connecting to a router (being used as wifi access point) on the same network. The router in question is a TP-Link WR740N. I am factory resetting the Core so that it starts flashing Blue. I unplug it and replug it in for good measure. Then I try to get it connected to wifi using the Android app on my phone (like I did for the Cisco). The Core starts blinking green and stays like that. Meanwhile, the android app says “no cores found”.

I have read around that it could be something to do with the android phone (a Samsung Galaxy S3 mini) using 5GHz rather than 2.4GHz but I don’t know how to check if it is the case and the router does not seem give me the option to choose (or maybe it is hidden under another setting like 11b/g/n).

So far I only find trouble shooting guides where the Spark didn’t work right out of the box. But in this case, it is clear that the problem is not with the Core, or at least not entirely.

Any guidance appreciated.

1 Like

One quick way to help debug this type of thing is to see if your router has an option to name the 5GHz and 2.4GHz bands with different SSIDs. That way you can be sure that your Android phone is on the 2.4GHz network with your Core.

4 Likes

You guessed right there - b/g only would also avoid the 5GHz issue.

Also choose a channel manually, rather then AUTO, to ensure channel <= 11

The other route you could go is to privide WiFi credentials via USB.

5 Likes

Actually it was manually set to channel 13. I set it to channel 8 and BAM, problem solved!

Thanks, both of you! I’m really impressed with the timeliness and helpfulness of this community!

5 Likes