What is the correct way to set up a Boron for personal sandbox?

I'm trying to set up a Boron 404x on my personal sandbox (no products), I get through the setup and update process, but then I get stuck at the "Organize" page. I have "Personal Sandbox" selected from the dropdown menu, I don't want to create a product for this, but there is no way to skip this part and go to the "Activate" tab. Alternatively, I've tried going to the WebIDE and putting in the device ID under "Claim New Device", but this functionality appears to have been removed since all I get is "Could Not Claim Device". Anybody know how to claim a device if you're not using it in a product?

Hi Michael- If you set up a Boron through that setup tool you must create a product, but you can set up a device without creating a product with the docs setup tool.

Hey Colleen, it looks like the Flash Device button on that page is a broken link. I can connect to the device, and it reads the information OK, but clicking Flash Device does nothing. I've tried two different computers, both on Chrome, one is Windows 7 with an older version, the other is Windows 11 with the most up to date version. Any ideas?

Edit:
Also tried Chrome in igcognito (shouldn't make a difference) and Microsoft edge, neither worked with the Flash Device button.

I ended up having to go a long way around the official setup process to get this device active. Using the CLI to get the device information, going to the console to activate the SIM based on the ICCID, then using the DeviceID and Particle cloud claim in the CLI to get the device claimed to my account once it was online. I was then able to go through the WebIDE to flash the device. Hopefully this is just a fluke and not an ongoing issue.