Particle setup fails; returns without finishing; cannot setup Boron

I am having unprecedented issues setting up and registering a Boron.

I cannot use the phone app because 1. the first time it hung on “Sending Part 1 to Device 100%” and I needed to exit, and because now the phone app says “Unable to find your mesh device …” even as it is flashing blue and cellular ant is attached.

Needing therefore to use Particle CLI in my Windows CMD, I type “particle setup” with Boron flashing blue, it ask me to use my account, I type “Y” then it just quits execution and does nothing:

immagine

I have tried particle doctor, particle usb reset in DFU mode, and flashing bootloader + tinker 1.5.0 rc-1.

For the life of me I cannot setup this brand new Boron I have purchased which does not appear to have any hardware defects at all.

More information:
When I first tried the phone app and encountered the “Sending to device: 100%” hang, when I canceled, I then went into my Particle Console and saw that the Boron did in fact register, just without a name and on 1.1.0. So I thought, “great, I’ll just update it manually with particle flash --usb “1.50.0 rc system part 1"”. So I did that. Then I reset and it began flashing blue again and entered the nonresponsive, unsetup state I am struggling with. Never before have I seen the mere act of updating Device OS unregister the device from the cloud. So I went and unclaimed it on the console (it would no longer connected to cloud after receiving 1.5.0 rc1 system part 1”, thinking this would revert me to factory. Now I seem permanently unable to use this Boron!

And to prove there is USB connection, here is the successful result of particle identify:

immagine

This is very frustrating. Any help?

Also, “particle doctor” fails even to execute rather than, having executed, fails to remedy the issue. Here is the output of “particle doctor”. I certify the device was put into yellow DFU mode before continuing:

IIRC particle setup is not meant to work on Borons.
You’d either need to do it via the mobile app or step by step yourself including setting the setup done flag (e.g. via dfu-util or a dedicated application firmware like this)

BTW, unclaiming a device that’s already owned by you never helps with anything but rather makes things more complicated.

I appreciate your response ScruffR.

I believe a reasonable person in my shoes, encountering these setup issues, would try unclaiming from the cloud having encountered the reversal to an apparent unactivated state. Although I now know this operation is counterproductive, it is a shame that I did not receive this information beforehand, however I wonder if my efforts to educate myself about the Particle Boron setup rules were unreasonably insufficient.

I am also wondering if it was unreasonable of a customer in my shoes to have lacked the knowledge that “particle setup” does not in fact work for Particle’s flagship product.

In order to be able to use my Boron and declare it not permanently destroyed due to my usage of a button on Particle’s Device Cloud API, I am trying to obey the “setup done” article to which you linked me.

However, it just references a code clip as “this firmware” and automatically assumes the existence of a compiled “dummy.bin” firmware file generated from this code.

How would a person take the setup done C code referenced in the snippet, and therefrom derive a compiled firmware “dummy.bin” file?

Thank you for your help.

You can use CLI (particle compile), Web IDE or Workbench to produce a binary.
In Web IDE you can use this icon to download the binary file for for local upload
image

BTW, if you try to unclaim a device via Web IDE you would have gotten a warning.
It is beyond me to see why CLI wouldn’t also do that despite us users (I’m not a Particle employee) asking for that warning repeatedly before :wink:

One of the obstacles created by unclaiming a device would be that you would not be able to go that route anymore - unless you had another Boron claimed - as Web IDE won’t let you target a platform you don’t have a claimed device for (another option I had been asking for before) - apart from the deprecated Spark Core.

Thank you for this help ScruffR, with which I was able to restore and use this Boron.

I imagine this thread will be a useful resource to any future individuals who manage to put their Boron into the seeming irrecoverable state I described.

For posterity, what I did was compile the setup done code in Particle cloud as ScruffR instructed, run the two CMD commands as stated in the setup done page (flashing to Boron in DFU mode), and then used “particle device add ___” to re-register under my cloud account.

Thanks again.

1 Like