New Boron won't connect to cellular during activation

I just bought my 1st Boron and during setup it won’t connect to cellular. I took the following steps:

  1. Unboxed and attached antenna.
  2. Turned it on, saw flashing green, but held down ‘mode’ button for 3 seconds until it flashed blue.
  3. From the iOS Particle app, paired to the Boron, activated the SIM.
  4. iOS setup flow fails on the “Your Boron is connecting to the Particle Device Cloud” screens. It hangs for a while, and eventually an error message appears saying it’s taking longer than expected (screenshot attached).

Notes:

  • The Boron light keeps flashing green all the while
  • I’ve tried this twice with same result, and have waited 15 minutes now with no change
  • On the SIM console, I see the SIM activated but without any devices associated to it
  • On the device console, I don’t see any devices

What might be happening and what else should I try? This is my 1st experience with a Particle device.



Update: after letting it sit for ~3 hours, the light changed from blinking green to solid light blue. So I tried the whole progress again, and this time, for the first time, it got past the “connecting to the internet via cellular” step, and then failed on the “starting a secure session with the particle device cloud” step, saying “Error: your device failed to be claimed. Please try again.”

(Btw, cell service for my phone is totally fine where I am right now. Not sure if there’s a way to check if that’s the issue on the Boron during the setup process via bluetooth).

@sam_grounded ,

I had very similar issues and it turns out that activating Borons using the app is no longer the recommended approach. Please take a look at this thread:

I now use this process:

  1. I use the “device restore” tool to update to the desired deviceOS version and check the box that turns off the setup bit.
  1. Put the device in listening mode and open up the command line tools in a terminal. Use the “particle identify” command (device in listening mode) to get the deviceID.
  2. Then, I add the device to the product I want to on-board it to using “particle product device add”. The device comes on, connects and gets the product’s firmware all in one go. Much quicker and easier than using the mobile app.
  3. Finally, I claim the device using the command line tools with “particle device add” and the deviceID.

I know the documentation will be updated and there may be a more efficient process but, this works and can go quite quickly.

Hope this helps,

Chip

1 Like

Ahh. Okay, they probably should remove the app from the iOS store? Anyway, got it all working now - thanks a ton, Chip!

@sam_grounded ,

I do believe the documentation pages will get updated. I still use the app to interact with my deployed devices using the particle variables and functions. That said, yes, it seems the iOS app should be updated or deprecated.

One step (added above) is to claim the device using the “particle device add” command followed by the deviceID.

Glad you are connected now.

Chip

@Colleen ,

I believe the setup page for the Boron still points here which directs folks to activate their Boron’s using the mobile app. I think this page needs to be updated so others don’t run into issues with the mobile app.

Thanks,

Chip

2 Likes

Thanks for pointing this out, Chip!

I’ll let the setup team know about this.