Web IDE Says Flash Successful.. But It's not actually being sent

Tonight while trying to update an Argon via the Web IDE, I am running into a strange situation where the Web IDE shows that the code is flashing and acts like everything is successful, but in reality the Argon is still breathing Cyan and is not getting the new code.

I have tried refreshing the IDE, I have tried power cycling the Argon, luckily this one isn’t out in the field and is in front of me on my desk or I’d really be scratching my head…

When I press the Flash button in the IDE I get:

Flashing code…
[wait 20 seconds]
Flash Successful! Your device is being updated.

This is normal behavior (or the IDE) but the code never makes it.

If I remove power from the Argon, then it times out.

Is this system wide at the moment?

I can’t seem to find a workaround for it.

Have you tried using Particle Workbench? It supports local flashing as well as cloud flashing.

No that’s not normal, but may be caused by application code.
Have you tried putting the device in Safe Mode before trying to flash?
When that works, it’s probably your code :wink: