Can't flash new firmware via Web IDE

Having an odd issue. When I flash via the Web IDE today it says success but the device doesn’t receive the firmware and the console show no entries that a flash was attempted. The device does show up as online in the console, ping returns successfully and I can see an event when I manually reset the device. I also tried putting my device in safe mode and all of the above still applies.

Is there an issue with the build/flash process on Particle’s side? The status page doesn’t mention anything.

Hate to ask it, but did you make sure to select the correct device in the devices tab? It should have a yellow star in front of its name. Wouldn’t be the first time I forgot to set that, and flash the wrong device :sweat_smile:

Yep, even used the signalling feature to confirm. I refreshed the page to make sure I hadn’t gotten logged out or somehow have a browser issue. The same issue remains even if I flash a blank program.

One thing I just realized, within the console no online/offline events show up nor that I put the device in safe mode. Only hitting the reset button causes an event to show up.

The signaling feature is separate from the device selection. You can ping any device, as long as they’re online, without it having to be selected as your flashing target.
Could you give incognito mode a shot, or a different browser entirely?

1 Like

Yep; but I use signalling to make sure I picked the right device, they all look alike :wink:

No difference using Incognito, nor with trying this with a different device, this time a Xenon. I’ve flashed probably 100+ times over the last week so it seems unlikely it’s a browser issue though it gave me an idea. I opened up chrome’s dev tools, network tab and checked the result of the flash command:

{“cmd”:“Event”,“name”:“Update”,“message”:“Flash requires modules not present on device”,“modules”:{“m”:[{“f”:“s”}]}}

This occurs even when flashing a blank program. So 2 bugs; the Web IDE isn’t showing an error when the server clearly returned one (or perhaps it’s the server returning a 200 with an error message instead of 500), and the underlying cause of this error.

@Fragma, I’ve had this problem from time to time with Chrome. It usually goes away if you open Settings on the web IDE and hit the CLEAR CACHE button. Have you tried this?

I wasn’t aware of that but I just tried it as well as chrome’s disable cache and got the same error in both.

Did you recently select a new version of system firmware to compile against? If so, could you try a lower version?
Alternatively, could you try updating your system OS using the (latest version of the) CLI with “Particle update”?

Nope, been on 0.9.0 since it came out. I tried picking lower and higher versions but no change.

Not sure if it helps but I see http calls for status which confirms version:
{“id”:“xxx”,“name”:“Argon-xxx”,“last_app”:null,“last_ip_address”:“73.xxx”,“last_heard”:“2019-05-02T00:29:46.336Z”,“product_id”:12,“connected”:true,“platform_id”:12,“cellular”:false,“notes”:null,“status”:“normal”,“serial_number”:“xxx”,“current_build_target”:“0.9.0”,“system_firmware_version”:“0.9.0”,“pinned_build_target”:“0.9.0”,“default_build_target”:“0.9.0”},

I tried with another computer, even a mobile phone, both show the flash successful message but the device nor the console show any signs of flashing.

I also tried IE, but couldn’t get past the particle login page, it claims a syntax error in app.js.

Is no one else having this problem?

Rebooting my router appears to have solved the problem. Any idea why?