Web IDE - No firmware available! [Solved]

Team Particle, seems to be a serious problem with the Web IDE at the moment.

Particle Devices menu displays “No firmware available” for all devices…

Hmm, I can see firmware available on all my device types (including compounds).
Have you tried clearing the cache?

@ScruffR, yep, cleared cache, same issue…

Now this is strange, is it possible that two people get different behaviour?

Will try on a different browser (currently Chrome on MacOSX). Back soon.

Safari on MaxOSX has the same issue. I do note that my Macbook does have issues in general, it needs to be retired…

I’m on Windows 8.1 and Chrome and also Windows 7 Firefox, both OK.
But I’m in Europe, so I might hit other servers than you.

And it’s still a bit early for our US Particle friends, so a normal ping might not help.
If it’s urgent I can page them out of bed :wink:

BTW, can you still build via CLI?

Okay, understood - different regions can have different issues.

Am thinking that it is localised to Australia. No need to wake up anyone - I can still cut code at least and save, just can’t burn anything.

Will be interesting to see if anyone else chips in with the same problem…

1 Like

I’ve left a note for them, once they come round :sunglasses:

CLI might be a good standby to have set up for building and flashing.

Must admit to never built via the CLI. Will try that now (might be a little while whilst I work it out)

@ScuffR, guess what?

Login Failed: Error: connect ETIMEDOUT

This could explain a few things…

Pretty easy.

particle compile photon <projectFolder> 

That will build against the default system (currently 0.5.3) and download a binary.

To target a specific system version just add --target 0.6.0-rc.2 (for, well, 0.6.0-rc.2)

One thing to be aware of tho’, is that your include statements for libraries have to be flattened:

#include "SomeLibrary/SomeLibtrary.h" 
// becomes
#include "SomeLibrary.h"

but obviously that’s currently also not working for you :neutral_face:

@ScruffR, thanks for the lesson - excellent.

But you are right, no can do.

Anyhow, let’s see what support comes back with. Maybe others will see the same problem.


@ScruffR, not sure if anyone actually fixed the issue or if it resolved itself, but it is working okay now.

Case closed!

1 Like

Glad you are up and running again @UMD. Thanks for the help @ScruffR!

Dave had seen some log entries which may have been related and did some tweaking, but he also said he’d respond here :confused:
However, good you’re up and running again :+1:

1 Like

I am having a similar issue. I just added a new Photon to my account. I was able to connect to Wifi, and when I click “Signal” under the Devices tab, it starts throwing rainbows, as expected. However, I am unable to flash code onto the device. Further, when I look in the Devices tab of Particle Build, the device is listed as “Other” instead of being listed as a “Photon”. Also, the selection box for “System target firmware” is grayed out and says “No firmware available”.


Try updating the bootloader using Particle CLI or DFU.

This seems to be an issue with the provisioning of that device.
Can you post a screenshot of the device tab?
Sorry to ask this, but is this really a Photon (have a photo)?
You could try CLEAR CACHE in the settings tap of Web IDE or use Incognito Mode in your browser.
What does particle list show the device as?
If you have a DeviceID @rickkas7 may be able to look up what's wrong with the device in the cloud DB.

If the device is listed as other instead of the correct type, it’s either part of a product, or it’s misconfigured on the cloud side. If you submit the device ID in a support ticket it can be taken care of either way.

1 Like

Today, the device is correctly listed as a Photon, but I am still unable to flash code to it. I have tried OTA flashing as well as CLI flashing. When I try CLI, I get the following error.

$ particle flash --serial O2_only.bin

sending file: O2_only.bin
Error writing firmware: Transfer cancelled

Update: I now tried DFU flashing, which also didn’t work.

$ particle flash --usb O2_only.bin
Error writing firmware: dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

Error during download get_status

This looks like a bootloader issue as @UMD has already pointed out.

Can you post the output you get from particle serial inspect?