[SOLVED] Web IDE build issue with 0.6.0-rc.2 (again)

Anyone suffering from the Web IDE not downloading a compiled application nor programming over the air?

I have seen problems like this before with the host running out of memory and the like.

It compiles and flashed for me, so it might be an issue on your end (flaky connection, ISP issues, etc).

@Moors7 thanks for getting back so quick - I just love our community!

Problem is also that it does not download the compiled code to the local drive - ie the “Compile and download firmware binary” cloud icon button… Just picked out the Tinker sample so as to ensure that it was nothing to do with the source code.



Strange indeed, since I can download .bin files. Could you try an incognito session to see if that makes any difference?

1 Like

@Moors7, update.

At the end of the compile, am seeing message:

The server has failed to process the request on time. Please try again.

Will try the incognito session now.

I seem to have a similar problem with the :cloud: download icon, but status page reports everything up and running.
We might page - I’ll have to confer with @Moors7

@UMD, what version are you targeting? I have no issue with 0.5.2 but with 0.6.0-rc.2


@ScruffR, most definitely something fishy.

Yep, 0.6.0-rc.2, will try 0.5.2 and report back.

@ScruffR, bingo! Selecting 0.5.2 solved the issue.

Who do we report this too?

we are already (discussing) paging Particle

@ScruffR, considering it is pre-release, probably not worthy of a page…

OK, we’ll hold off then, till we might see more reports - thanks for the diligence and consideration!

@Scruffr, but it will be reported right? Am just saying that there is no need to pull anyone out of bed, it can be sorted during Particle business hours.

1 Like

It won’t get lost!

Thanks for letting us know. We’re on it!


We’re back online with the 0.6.0-rc.2 compiler. Thanks for your patience.

A post was merged into an existing topic: Having trouble finding documentation for emulating a keyboard

Same here

and when I try to head over to my console.

Hey folks,

As far as we know the compile service is working perfectly with both prereleases and normal releases. There was an issue earlier today, but simply redeploying the app fixed it. If you see any issues, please let us know.

@jackpot your issue is different. Please try going to the following URL in your browser, substituting your access token where it says YOUR_TOKEN:


Thanks for the reply. I tried as you said and the page will not load. The address in the browser reverts back to the link shown above. In other words, I place the link you provided in the address field and then paste in my token, the site does not respond and then the address goes back to the instance without my token.

Hope that makes sense
Thank you

I tired it again. Although the results are the same, at least this time when i placed my token in the address it stayed there!